ACM-ICPC 2018 南京赛区网络预赛 AC Challenge (dp+状态压缩)

Dlsj is competing in a contest with n(0<n≤20)n (0 < n \le 20)n(0<n≤20) problems. And he knows the answer of all of these problems.

However, he can submit iii-th problem if and only if he has submitted (and passed, of course) sis_isi​ problems, the pi,1p_{i, 1}pi,1​-th, pi,2p_{i, 2}pi,2​-th, ........., pi,sip_{i, s_i}pi,si​​-th problem before.(0<pi,j≤n,0<j≤si,0<i≤n)(0 < p_{i, j} \le n,0 < j \le s_i,0 < i \le n)(0<pi,j​≤n,0<j≤si​,0<i≤n) After the submit of a problem, he has to wait for one minute, or cooling down time to submit another problem. As soon as the cooling down phase ended, he will submit his solution (and get "Accepted" of course) for the next problem he selected to solve or he will say that the contest is too easy and leave the arena.

"I wonder if I can leave the contest arena when the problems are too easy for me."
"No problem."
—— CCF NOI Problem set

If he submits and passes the iii-th problem on ttt-th minute(or the ttt-th problem he solve is problem iii), he can get t×ai+bit \times a_i + b_it×ai​+bi​ points. (∣ai∣,∣bi∣≤109)(|a_i|, |b_i| \le 10^9)(∣ai​∣,∣bi​∣≤109).

Your task is to calculate the maximum number of points he can get in the contest.

Input

The first line of input contains an integer, nnn, which is the number of problems.

Then follows nnn lines, the iii-th line contains si+3s_i + 3si​+3 integers, ai,bi,si,p1,p2,...,psia_i,b_i,s_i,p_1,p_2,...,p_{s_i}ai​,bi​,si​,p1​,p2​,...,psi​​as described in the description above.

Output

Output one line with one integer, the maximum number of points he can get in the contest.

Hint

In the first sample.

On the first minute, Dlsj submitted the first problem, and get 1×5+6=111 \times 5 + 6 = 111×5+6=11 points.

On the second minute, Dlsj submitted the second problem, and get 2×4+5=132 \times 4 + 5 = 132×4+5=13 points.

On the third minute, Dlsj submitted the third problem, and get 3×3+4=133 \times 3 + 4 = 133×3+4=13 points.

On the forth minute, Dlsj submitted the forth problem, and get 4×2+3=114 \times 2 + 3 = 114×2+3=11 points.

On the fifth minute, Dlsj submitted the fifth problem, and get 5×1+2=75 \times 1 + 2 = 75×1+2=7 points.

So he can get 11+13+13+11+7=5511+13+13+11+7=5511+13+13+11+7=55 points in total.

In the second sample, you should note that he doesn't have to solve all the problems.

样例输入1复制

5
5 6 0
4 5 1 1
3 4 1 2
2 3 1 3
1 2 1 4

样例输出1复制

55

样例输入2复制

1
-100 0 0

样例输出2复制

0

题目来源

ACM-ICPC 2018 南京赛区网络预赛

解题思路:

dp题

用二进制数表示已经做了哪些题,读入时用problem[].need表示做这道题时需要已经做了哪些题。

dp从小到大扫一遍,即1->2^n-1。

当i=11010(二进制)时,

dp[11010]是在dp[11000]+第二题得分、dp[10010]+第四题得分、dp[01010]+第5题得分中取最大值,以此类推。

先处理小数,再处理大数。当处理大数时,小数已经处理好了(可以利用了)

在dp的同时需要判断是否满足题目所给的做题顺序。i(二进制)所含1的数量为当前做题数(时间)。


STL状态压缩神器:

bitset(使用时注意,转化出来的二进制数是倒着的) 

 c++ bitset类用法

C++ bitset 用法


#include<stdio.h>
#include<bitset>
using namespace std;

struct Problem
{
    int a,b,s,need;
}problem[25];
long long state[1<<22];

int main()
{
    int n,p;
    long long answer=0;
    scanf("%d",&n);
    int maxn=1<<n;
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d%d",&problem[i].a,&problem[i].b,&problem[i].s);
        problem[i].need=0;
        for(int j=1;j<=problem[i].s;j++)
        {
            scanf("%d",&p);
            problem[i].need|=1<<p-1;
        }
    }
    for(int i=1;i<=maxn;i++)
    {

        bitset<20> put(i);/**从0开始放**/
        int time=put.count();
        for(int j=0;j<n;j++)
        {
            if(put[j]==1)
            {
                int change=(1<<j)^i;
                int now=j+1;
                //printf("j=%d now=%d change=%d\n",j,now,change);
                //printf("problem[now].need=%d change=%d problem[now].need&change=%d\n",problem[now].need,change,problem[now].need&change);
                if(change==0)
                {
                    if((problem[now].need&change)==problem[now].need)
                        state[i]=max(state[i],state[change]+time*problem[now].a+problem[now].b);
                    else
                        continue;
                }
                else if(state[change]&&(problem[now].need&change)==problem[now].need)
                {
                    state[i]=max(state[i],state[change]+time*problem[now].a+problem[now].b);
                }

                answer=max(answer,state[i]);
                //printf("state[%d]=%lld answer=%lld\n",i,state[i],answer);
            }
        }
    }
    printf("%lld\n",answer);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值