POJ1703 Find them, Catch them【种类并查集】

Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 54120 Accepted: 16572

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

问题链接:POJ1703 Find them, Catch them

问题描述:给定N个人(从1开始编号),这N个人均属于两个组中的一个组。共M次操作,操作一D a b表示a和b不是一个组,A a b表示查询a和b是否在一个组,不能确定输出Not sure yet.,不再同一个组输出In different gangs.,在同一个组输出In the same gang.

解题思路:种类并查集。pre存储i的父节点 r存储i和父节点的关系,0表示i和父节点是同一组,1表示不是同一组 。具体看代码

AC的C++代码:

#include<iostream>

using namespace std;

const int N=100010;

int pre[N],r[N];//pre存储i的父节点 r存储i和父节点的关系,0表示i和父节点是同一组,1表示不是同一组 
void init(int n)
{
	for(int i=0;i<=n;i++){
		pre[i]=i;//自己为自己的父节点 
		r[i]=0;//自己与自己是同一组 
	}
}

int find(int x)
{
	if(x!=pre[x]){
		int rt=pre[x];
		pre[x]=find(rt);
		r[x]^=r[rt];
	}
	return pre[x];
}

void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){//fx和fy是两颗树,合并 
		pre[fy]=fx;
		r[fy]=1^r[x]^r[y];//求fy和其父节点fx的关系:y和fy的关系是r[y],y和x的关系是1,x和fx的关系是r[x], 
	}
}

int main()
{
	int n,m,t,a,b,x;
	char c;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		init(n);
		while(m--){
			scanf(" %c%d%d",&c,&a,&b);
			if(c=='D')
			  join(a,b);
			else if(c=='A'){
				int fa=find(a);
				int fb=find(b);
				if(fa!=fb)
				  printf("Not sure yet.\n");
				else{
					if(r[a]!=r[b])
					  printf("In different gangs.\n");
					else
					  printf("In the same gang.\n");
				}
			}
		}
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值