POJ2406 Power Strings【KMP】

Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 60347 Accepted: 24982

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01

问题链接:POJ2406 Power Strings

问题描述:问字符串S有多少个循环节

解题思路:KMP算法的next数组的运用。len-next[len]表示循环节的长度 L 。当 len% L != 0时,表示只有一个循环节(即字符串本身),否则为len/L个循环节

AC的C++程序:

#include<iostream>
#include<cstring>

using namespace std;

const int N=1000010;
char p[N];
int Next[N];

void GetNext(char p[],int next[])
{
	next[0]=-1;
	int k=-1,j=0,plen=strlen(p);
	while(j<plen)
	{
		//p[k]表示前缀 p[j]表示后缀
		if(k==-1||p[k]==p[j])
		{
			k++;
			j++;
			next[j]=k;
		}
		else
		  k=next[k]; 
	}
}

int main()
{
	while(~scanf("%s",p)&&p[0]!='.')
	{
		GetNext(p,Next);
		int plen=strlen(p);
		int l=plen-Next[plen];//循环节长度
		if(plen%l==0)
		  printf("%d\n",plen/l); 
		else
		  printf("1\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值