HDU3592 World Exhibition【差分约束】

World Exhibition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2179    Accepted Submission(s): 1072


 

Problem Description

Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.

Input

First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y. 

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.

Output

For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.

Sample Input

1
4 2 1
1 3 8
2 4 15
2 3 4

Sample Output

19

Author

alpc20

Source

2010 ACM-ICPC Multi-University Training Contest(15)——Host by NUDT

问题链接:HDU3592 World Exhibition

参见:POJ3169 Layout【差分约束】

AC的C++程序:

#include<iostream>
#include<cstring>
#include<vector> 
#include<queue>
#include<algorithm>

using namespace std;

const int N=1010;
const int INF=0x3f3f3f3f;

struct Edge{
	int v,w;
	Edge(int v,int w):v(v),w(w){}
};

vector<Edge>g[N];

int dist[N];
int cnt[N];
bool vis[N];
int n;

bool spfa(int s)
{
	memset(vis,false,sizeof(vis));
	fill(dist,dist+n+1,INF);
	memset(cnt,0,sizeof(cnt));
	queue<int>q;
	q.push(s);
	dist[s]=0;
	cnt[s]=1;
	vis[s]=true;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=false;
		for(int i=0;i<g[u].size();i++)
		{
			int v=g[u][i].v;
			int w=g[u][i].w;
			if(dist[v]>dist[u]+w)
			{
				dist[v]=dist[u]+w;
				if(!vis[v])
				{
					q.push(v);
					vis[v]=true;
					if(cnt[v]++>n)//存在负环 
					  return false;
				}
			}
		}
	}
	return true; 
}

int main()
{
	int t,x,y,a,b,c;
	scanf("%d",&t);
	while(t--)
	{
		for(int i=0;i<N;i++)
		  g[i].clear();
		scanf("%d%d%d",&n,&x,&y);
		while(x--)
		{
			scanf("%d%d%d",&a,&b,&c);
			g[a].push_back(Edge(b,c));
		}
		while(y--)
		{
			scanf("%d%d%d",&a,&b,&c);
			g[b].push_back(Edge(a,-c));
		}
		for(int i=2;i<=n;i++)
		  g[i].push_back(Edge(i-1,0)); 
		bool flag=spfa(1);
		if(flag)
		  printf("%d\n",dist[n]==INF?-2:dist[n]);
		else
		  printf("-1\n");//存在负环表示不存在 
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值