HDU3183 A Magic Lamp【贪心】

A Magic Lamp

http://acm.hdu.edu.cn/showproblem.php?pid=3183

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7201    Accepted Submission(s): 2876


 

Problem Description

Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?

 

Input

There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.

 

Output

For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 

 

Sample Input

178543 4 
1000001 1
100001 2
12345 2
54321 2

Sample Output

13
1
0
123
321

Source

HDU 2009-11 Programming Contest

 

题意

给你一个不超过1000位的非负整数n(没有前导零)和一个整数m(m不大于n的位数),问删除m位,使得剩下的数位形成的数最小。

思路

贪心法,先考虑高位,在考虑低位,由于能够删除m位,因此我们在[0,m]中选择第一个最小的数位作为新数的最高位,设此位的位置为k,然后再在[k+1,k+1+(m-1)]中选择第一个最小的数位作为此高位......直到形成一个长度为原长度-m的数,由于结果可能出现前导零,因此要删除前导零。

C++代码

#include<iostream>
#include<string>


using namespace std;

int main()
{
	string s;
	int m;
	while(cin>>s>>m)
	{
		if(s.length()==m)//全删除,结果为0 
		{
			cout<<"0\n";
			continue;
		}
		string ans="";//存放结果 
		for(int i=0,len=s.length()-m;i<s.length()&&ans.length()<len;)
		{ 
			//在[i,i+m]中选择最小的数 
			int k=i;
			for(int j=i;j<=i+m&&j<s.length();j++)
				if(s[k]>s[j])
					k=j;
			ans+=s[k];
			m-=k-i;//更新m 
			i=k+1;
		}
		//处理前导0后输出结果 
		int i;
		for(i=0;i<ans.length()-1&&ans[i]=='0';i++);
		while(i<ans.length()) cout<<ans[i++];
		cout<<"\n";
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值