POJ2528 Mayor's posters【离散化+线段树区间修改】

Mayor's posters

http://poj.org/problem?id=2528

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 83540 Accepted: 23993

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 

  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source

Alberta Collegiate Programming Contest 2003.10.18

题意

城市里要竞选市长,然后在一块墙上可以贴海报为自己拉票,每个人可以贴连续的一块区域,后来贴的可以覆盖前面的,问到最后一共可以看到多少张海报。整块墙可以看成一个数轴,每张海报就是数轴上的一个区间。

思路

线段树区间修改+离散化。color[rt]记录结点rt控制的区间的颜色,初始为-1

C++代码

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1

const int M=10010;
const int N=40100;

int color[N<<2],vis[N],ans;

void pushdown(int rt)
{
	if(color[rt]!=-1)
	{
		color[rt<<1]=color[rt<<1|1]=color[rt];
		color[rt]=-1;
	}
}

//将区间[L,R]染成颜色v 
void update(int L,int R,int v,int l,int r,int rt)
{
	if(L<=l&&r<=R)
	{
		color[rt]=v;
		return;
	}
	pushdown(rt);
	int m=(l+r)>>1;
	if(L<=m)
	  update(L,R,v,ls);
	if(R>m)
	  update(L,R,v,rs);
}

void query(int l,int r,int rt)
{
	if(color[rt]!=-1)
	{
		if(!vis[color[rt]])
		{
			ans++;
			vis[color[rt]]=true;
		}
		return;
	}
	if(l==r) return;
	int m=(l+r)>>1;
	query(ls);
	query(rs);
}

int l[M],r[M],cnt[N];

int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n,k=0;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&l[i],&r[i]);
			cnt[k++]=l[i];
			cnt[k++]=r[i];
		}
		sort(cnt,cnt+k);
		k=unique(cnt,cnt+k)-cnt;
		int end=k;
		for(int i=1;i<end;i++)
		{
			if(cnt[i-1]+1!=cnt[i])
			  cnt[k++]=cnt[i-1]+1;//使得原本不相邻的元素离散化后依然不连续 
		}
		sort(cnt,cnt+k);//由于新加入了点,因此需要从小排序
		memset(color,-1,sizeof(color));
		//遍历n个海报 
		for(int i=0;i<n;i++)
		{
			//获取它的离散化后的值
			int L=lower_bound(cnt,cnt+k,l[i])-cnt+1;
			int R=lower_bound(cnt,cnt+k,r[i])-cnt+1;
			update(L,R,i,1,k,1); 
		}
		ans=0;
		memset(vis,0,sizeof(vis));
		query(1,k,1);
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值