HDU1542 Atlantis【线段树+扫描线+离散化】

Atlantis

http://acm.hdu.edu.cn/showproblem.php?pid=1542

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21633    Accepted Submission(s): 8576


 

Problem Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

 

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

 

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output 

Test case #1
Total explored area: 180.00 

Source

Mid-Central European Regional Contest 2000

题意

二维平面有n个平行于坐标轴的矩形,现在要求出这些矩形的总面积,重叠部分只能算一次。

思路

线段树+扫描线,cnt[i]表示i控制区间的下位边-上位边的值,如果值为-1表示它左、右孩子的cnt[]值不一致。sum[i]表示i控制的区间中cnt[]值大于0的区间的长度。注意,线段树中每个叶节点(控制区间[L,L])不是指x[L]坐标,而是指区间[x[L],x[L+1]].线段树中其他节点控制的区间[L,R],也是指的x坐标轴的第L个区间到第R个区间的范围,也就是x[L]到x[R+1]坐标的范围。

C++代码

#include<iostream>
#include<algorithm>

using namespace std;

#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1

const int N=250;

struct Node{
	double l,r,h;
	int d;
	Node(){}
	Node(double l,double r,double h,double d):l(l),r(r),h(h),d(d){}
	bool operator<(const Node &t)const
	{
		return h<t.h;
	}
}nodes[N<<1];

int cnt[N<<2];
double sum[N<<2],x[N<<1];


void pushup(int rt)
{
	if(cnt[rt<<1]==-1||cnt[rt<<1|1]==-1||cnt[rt<<1]!=cnt[rt<<1|1])
	  cnt[rt]=-1;
	else
	  cnt[rt]=cnt[rt<<1];
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void build(int l,int r,int rt)
{
	if(l==r)
	{
		cnt[rt]=0;
		sum[rt]=0.0;
		return;
	}
	int m=(l+r)>>1;
	build(ls);
	build(rs);
	pushup(rt);
}

void pushdown(int l,int r,int rt)
{
	if(cnt[rt]!=-1)
	{
		int m=(l+r)>>1;
		cnt[rt<<1]=cnt[rt<<1|1]=cnt[rt];
		sum[rt<<1]=(cnt[rt]?x[m+1]-x[l]:0);
		sum[rt<<1|1]=(cnt[rt]?x[r+1]-x[m+1]:0); 
	}
}

void update(int L,int R,int C,int l,int r,int rt)
{
	if(L<=l&&r<=R)
	{
		if(cnt[rt]!=-1)
		{
			cnt[rt]+=C;
			sum[rt]=(cnt[rt]?x[r+1]-x[l]:0);
			return;
		}
	}
	pushdown(l,r,rt);
	int m=(l+r)>>1;
	if(L<=m)
	  update(L,R,C,ls);
	if(R>m)
	  update(L,R,C,rs);
	pushup(rt);
}

int main()
{
	int q,t;
	while(~scanf("%d",&q)&&q)
	{
		int n=0,m=0;
		for(int i=1;i<=q;i++)
		{
			double x1,y1,x2,y2;
			scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
			x[++n]=x1;//左端点
			x[++n]=x2;//右端点 
			nodes[++m]=Node(x1,x2,y1,1);//下位边 
			nodes[++m]=Node(x1,x2,y2,-1);//上位边 
		}
		sort(x+1,x+n+1);//对x坐标排序 
		sort(nodes+1,nodes+m+1); //对上位边、下位边进行排序 
		n=unique(x+1,x+n+1)-(x+1);//去除相同的x坐标,进行离散化
		build(1,n-1,1);
		double ans=0;
		for(int i=1;i<m;i++)
		{
			int l=lower_bound(x+1,x+n+1,nodes[i].l)-x;
			int r=lower_bound(x+1,x+n+1,nodes[i].r)-x-1;
			if(l<=r) update(l,r,nodes[i].d,1,n-1,1);
			ans+=sum[1]*(nodes[i+1].h-nodes[i].h); 
		}
		printf("Test case #%d\nTotal explored area: %.2lf\n\n",++t,ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值