hdu---1016Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22757    Accepted Submission(s): 10134


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input
n (0 < n < 20).
 

 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

 

Sample Input
6 8
 

 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 
//一个简单的回溯   记得还原vis[]数组即可
Code:
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#define N 100010
int f[31];int n;int vis[32];
int viss[100];int num;
//素数环,一个搜索回溯的题目
void dfs(int t){ //需要一个标记数组
    int i;
        if(t==n+1){
            if(viss[f[n]+1]==0){
                for(i=1;i<=n;i++){
                    if(i>1) printf(" ");
                    printf("%d",f[i]);
                }
                printf("\n");
            }
        }
        else{
            for(i=2;i<=n;i++){
                if(vis[i]==0 && viss[i+f[t-1]]==0){
                    f[t]=i;vis[i]=1;
                    dfs(t+1);
                    vis[i]=0;//需要还原;
                }
            }
        }
}
int main()
{
    freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int i,j,k;
    int m=sqrt(100+0.5);
    memset(viss,0,sizeof(viss));
    for(i=2;i<=m;i++)
        if(!viss[i]){
            for(j=i*i;j<=100;j=j+i) viss[j]=1;
        }//vis中为0的即为素数,其中素数又保存在了prime数组中!c为素数总数。
    num=1;
    while(scanf("%d",&n)!=EOF){
        f[1]=1;vis[1]=1;
        memset(vis,0,sizeof(vis));

        printf("Case %d:\n",num++);
        dfs(2);
        printf("\n");
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值