SDNUOJ 1705.Fibonacci plus

Time Limit: 10 MS    Memory Limit: 32768 KB
Total Submission(s): 103    Accepted Submission(s): 38

Description

There are another kind of Fibonacii: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2)

Input

Input sonsists of a sequence of lines, each containing an interger n. (n<10^20)

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

Hint

水题

Source

bhq

key:

怎么输入n

附上AC代码:

#include<bits/stdc++.h>
using namespace std;

string a;
int x=0,c=0;

int main()
{
	while(getline(cin, a))
	{
		c=a.length();
		if(c==1)
			x=a[0]-'0';
		else
			x=(a[c-2]-'0')*10+(a[c-1]-'0');
			
		if(x%4==2)
			printf("yes\n");
		else
			printf("no\n");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值