HDU-1024 java 实现

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33847    Accepted Submission(s): 12057


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
 
 
1 3 1 2 32 6 -1 4 -2 3 -2 3
 
Sample Output
 
 

68


最大M子段和,求一个数组中分成M段取数,最大的和是多少。
import java.util.Scanner;
public class pro1024 {
	public static void main(String[] args) {
		// TODO 自动生成的方法存根
      Scanner cin=new Scanner(System.in);
      while(cin.hasNext())
      {
    	  int m=cin.nextInt();
    	  int n=cin.nextInt();
    	  int []num=new int[n+1];
    	  int dp[]=new int[n+1];
    	  for(int i=1;i<=n;i++)
    	  {  
    		  num[i]=cin.nextInt();
    	  }
    	 int mmmax=-2100000000;
    	  int jmax[]=new int [n+1];  
    	  for(int i=1;i<=m;i++)
    	  {
    		  mmmax=-2100000000;
    		  for(int j=i;j<=n;j++)
    		  {
    			  dp[j]=Math.max(dp[j-1]+num[j], jmax[j-1]+num[j]);			
                  jmax[j-1]=mmmax;
                  mmmax=Math.max(mmmax, dp[j]);
    		  }
    	  }
    	  System.out.println(mmmax);
      }
	}

}


核心代码来自于http://blog.csdn.net/youchengyuanzhi/article/details/8875354
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值