Ignatius and the Princess IV
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32767 K (Java/Others)Total Submission(s): 39731 Accepted Submission(s): 17315
Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.
"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.
"But what is the characteristic of the special integer?" Ignatius asks.
"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.
Can you find the special integer for Ignatius?
"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.
"But what is the characteristic of the special integer?" Ignatius asks.
"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.
Can you find the special integer for Ignatius?
Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
Output
For each test case, you have to output only one line which contains the special number you have found.
Sample Input
51 3 2 3 3111 1 1 1 1 5 5 5 5 5 571 1 1 1 1 1 1
Sample Output
351
此题java貌似过不了(说不定那种BufferedReader的读取方法可以过???没试过),下面贴上复杂度n的摩尔投票代码
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
// TODO 自动生成的方法存根
Scanner cin=new Scanner(System.in);
while(cin.hasNext())
{
int N=cin.nextInt();
int x;
int maxnum=-1;
int count=0;
for(int i=0;i<N;i++)
{
x=cin.nextInt();
if(count==0)
{
maxnum=x;
count=1;
}
else if(maxnum==x)
{
count++;
}
else count--;
}
System.out.println(maxnum);
}
}
}
摩尔投票,赠送网址一个http://mabusyao.iteye.com/blog/2223195
------------------------------------------------------------------------------------------
今天闲着没事,试了试BufferedReader,又参考了别人写的别的题目的用法,没想到真的过了
贴上代码:
import java.util.Scanner;
import java.io.BufferedReader;
import java.io.InputStreamReader;
public class Main {
public static void main(String[] args) {
try{
BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
while(true)
{
String s=br.readLine();
if(s.equals(""))continue;
int N=Integer.parseInt(s.trim());
int x;
int maxnum=-1;
int count=0;
String str=br.readLine().trim();
String strings[]=str.split(" ");
for(int i=0;i<N;i++)
{
x=Integer.parseInt(strings[i]);
if(count==0)
{
maxnum=x;
count=1;
}
else if(maxnum==x)
{
count++;
}
else count--;
}
System.out.println(maxnum);
}
}catch(Exception e){
}
}
}