1020 Tree Traversals (25 分)

 

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

C:

/*
 @Date    : 2017-12-01 12:59:48
 @Author  : 酸饺子 (changzheng300@foxmail.com)
 @Link    : https://github.com/SourDumplings
 @Version : $Id$
*/

/*
https://www.patest.cn/contests/pat-a-practise/1020
 */

#include <stdio.h>
#include <stdlib.h>

const int maxn = 30;

void Solve(int T[], int r, int p[], int ps, int pe, int in[], int ins, int ine)
{
    int n = pe - ps + 1;
    if (n >= 1)
    {
        T[r] = p[pe];
        if (n == 1)
        {
            return;
        }
        else
        {
            int i;
            for (i = ins; i <= ine; i++)
            {
                if (in[i] == p[pe])
                {
                    break;
                }
            }
            Solve(T, 2*r, p, ps, ps+i-ins-1, in, ins, i-1);
            Solve(T, 2*r+1, p, ps+i-ins, pe-1, in, i+1, ine);
        }
    }
    else
    {
        return;
    }
}

int main()
{
    int p[maxn], in[maxn];
    int N;
    scanf("%d", &N);
    int i;
    int T[10001] = {0};
    for (i = 0; i < N; i++)
    {
        scanf("%d", &p[i]);
    }
    for (i = 0; i < N; i++)
    {
        scanf("%d", &in[i]);
    }
    Solve(T, 1, p, 0, N-1, in, 0, N-1);
    int output = 0;
    for (i = 1; i <= 10000 && output <= N; i++)
    {
        if (T[i])
        {
            if (output++)
            {
                putchar(' ');
            }
            printf("%d", T[i]);
        }
    }
    putchar('\n');
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值