POJ 3714 Raid(求两集合之间的最近点对)

Raid

Description

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union's attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

Input

The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 100000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

Output

For each test case output the minimum distance with precision of three decimal placed in a separate line.

Sample Input

2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0

Sample Output

1.414
0.000

【思路分析】

   求平面上的最近点对,但是加了一个集合之间的限制。求距离的流程还是和简单的求平面最近点对是一样的,需要注意的就是要对每一个点进行标记,如果两个点属于同一个集合,则将其之间的距离赋值为INF,如果不属于同一个集合,直接求距离就好了。(ps:提交时用G++%lf会WA,改成C++就可以了)


代码如下:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define INF 1e10
const int maxn = 100005;
int n;
double ans;
int a[2 * maxn];
struct Point
{
    double x,y;
    int flag;//-1表示agent,1表示station
}points[2 * maxn];

int cmpX(const Point &a,const Point &b)
{
    return a.x < b.x;
}
int cmpY(const int &a,const int &b)
{
    return points[a].y < points[b].y;
}
double distances(int a,int b)
{
    return sqrt((points[a].x - points[b].x) * (points[a].x - points[b].x) + (points[a].y - points[b].y) * (points[a].y - points[b].y));
}
double closet(int l,int r)
{
    if(l == r)
        return INF;
    if(l + 1 == r && points[l].flag * points[r].flag < 0)//两个相邻点并且一个为agent一个为station
        return distances(l,r);
    if(l + 1 == r && points[l].flag * points[r].flag > 0)//两个相邻点并且在同一个集合
        return INF;
    int mid = (l + r) >> 1;
    double d1 = closet(l,mid);
    double d2 = closet(mid + 1,r);
    double d = d1 < d2 ? d1 : d2;
    int num = 0;//记录和中间点横坐标相差小于d的点
    for(int i = l;i <= r;i++)
    {
        if(fabs(points[mid].x - points[i].x) < d)
        {
            a[num] = i;
            num++;
        }
    }
    sort(a,a + num,cmpY);//按纵坐标排序
    for(int i = 0;i < num - 1;i++)
    {
        for(int j = i + 1;j <= i + 6 && j < num;j++)
        {
            if(points[a[j]].y - points[a[i]].y >= d)
                break;
            if(points[a[i]].flag * points[a[j]].flag < 0)
                d = d < distances(a[i],a[j]) ? d : distances(a[i],a[j]);
        }
    }
    return d;
}
void init()
{
    for(int i = 0;i < n;i++)
    {
        scanf("%lf %lf",&points[i].x,&points[i].y);
        points[i].flag = 1;
    }
    for(int i = n;i < 2 * n;i++)
    {
         scanf("%lf %lf",&points[i].x,&points[i].y);
         points[i].flag = -1;
    }
    sort(points,points + 2 * n,cmpX);
}
void solve()
{
    ans = closet(0,2 * n - 1);
    printf("%.3lf\n",ans);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        init();
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值