HDU 1018 Big Number(斯特林公式)

Big Number

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
7
19

【思路分析】
   求n!的位数。首先对于一个整数n,它的位数为log10(n) + 1,则log10(n!) = log10(n * (n - 1) * (n - 2) * .......*1) = log10(n) + log10(n - 1) + log10(n - 2) + ........+ log10(1)。所以求n!的位数,根据上式一个for循环就可以搞定。
   除此之外,还有一个斯特林公式可以在O(1)的时间内得到n!的位数s:s = (t * log(t) - t + 0.5 * log(2 * t * pi)) / log(10.0) + 1。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
int n;
void init()
{
    scanf("%d",&n);
}
void solve()
{
    double sum = 0;
    for(int i = 1;i <= n;i++)
    {
        sum += log10(double(i));
    }
    printf("%d\n",(int)sum + 1);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        solve();
    }
    return 0;
}


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const double pi = 3.1415926;
int n;
void init()
{
    scanf("%d",&n);
}
void solve()
{
    double s = n;
    s = (s * log(s) - s + 0.5 * log(2 * s * pi)) / log(10.0);
    printf("%d\n",(int)s+ 1);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值