POJ 2418 Hardwood Species(二叉搜索树BST)

Hardwood Species

Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.
America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483


【思路分析】

   题意要求输入很多单词,里面可能有重复的,统计每个单词出现次数占单词总数的百分比,最后按照字典序输出结果。

   用的是BST来进行字符串的存取和查找的,通过字符串是否出现过或者比较两个字符串的值来建树,这样建完树之后再中序遍历一遍就可以得到最终的结果了。


代码如下:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn = 35;
struct Node
{
    char name[maxn];
    struct Node *l,*r;
    int counts;
}tree;
Node *root;
int n = 0;
double ans;
char s[maxn];
void insertBST(struct Node **root,char *s)
{
    if(*root == NULL)//对应的结点不存在该单词
    {
        struct  Node *p = (struct Node *)malloc(sizeof(tree));
        strcpy(p->name,s);//单词赋值给新节点
        p->l = p->r = NULL;
        p->counts = 1;
        *root = p;
    }
    else
    {
        if(strcmp(s,(*root)->name) == 0)//找到相同的单词
        {
            ((*root)->counts)++;
            return;
        }
        else if(strcmp(s,(*root)->name) < 0)//插入单词小于当前结点单词
        {
            insertBST(&((*root)->l),s);//插入当前单词的左子树
        }
        else//插入单词大于当前结点单词
        {
            insertBST(&((*root)->r),s);
        }
    }
}
void midCal(struct Node *root)//中序遍历得到最终单词顺序
{
    if(root != NULL)
    {
        midCal(root->l);
        ans = ((double)(root->counts) / (double)(n)) * 100;
        printf("%s %.4lf\n",root->name,ans);
        midCal(root->r);
    }
}
void init()
{
    insertBST(&root,s);
    n++;
}
void solve()
{
    midCal(root);
}
int main()
{
    while(gets(s) != NULL)
    {
        init();
    }
    solve();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值