Broken Necklace

Description

You have a necklace of N red, white, or blue beads (3<=N<=350) some of which are red, others blue, and others white, arranged at random. Here are two examples for n=29:

The beads considered first and second in the text that follows have been marked in the picture.

The configuration in Figure A may be represented as a string of b's and r's, where b represents a blue bead and r represents a red one, as follows: brbrrrbbbrrrrrbrrbbrbbbbrrrrb .

Suppose you are to break the necklace at some point, lay it out straight, and then collect beads of the same color from one end until you reach a bead of a different color, and do the same for the other end (which might not be of the same color as the beads collected before this).

Determine the point where the necklace should be broken so that the most number of beads can be collected.


Example

For example, for the necklace in Figure A, 8 beads can be collected, with the breaking point either between bead 9 and bead 10 or else between bead 24 and bead 25.

In some necklaces, white beads had been included as shown in Figure B above. When collecting beads, a white bead that is encountered may be treated as either red or blue and then painted with the desired color. The string that represents this configuration will include the three symbols r, b and w.

Write a program to determine the largest number of beads that can be collected from a supplied necklace.

Input

Line 1: N, the number of beads
Line 2: a string of N characters, each of which is r, b, or w

Output

A single line containing the maximum of number of beads that can be collected from the supplied necklace.

Sample Input

29
wwwbbrwrbrbrrbrbrwrwwrbwrwrrb
 

Sample Output

11

 


决心不当潜水员了, 第一次写文章,第一次亮自己的代码,哈哈,献下丑

 主要思想是遍历每个点,把从每个点能取到的连续两种颜色的个数存在一个数组num中,数组中最大的数就是要求的。

     比如第i个节点是w ,先往下找到第一个不是w的点,假设这个点是r,那接下来找往下的第一个b,那这个是b的点到i之间的点的个数就是num[i]所存的

#include<stdio.h>
char beads[351];
int  num[351];//记录每个节点可以连续的节点个数
int n;
int judge(int a);
int main()
{
 int i,k;
 while(scanf("%d",&n)!=EOF)
 {

    for(i=0;i<350;i++)
             num[i]=0;

    scanf("%s",beads);
    for(i=0;i<n;i++)
   {
           num[i]=judge(i);
    }

 for(i=1,k=0;i<=n;i++)
 {
  if(num[i]>k)
   k=num[i];
 }
 printf("%d/n",k);
 }

 return 0;
}
int judge(int a)
{

 int  i,j;

 if(beads[a]=='w')
 {
     i=a;
  
  while(beads[i]=='w')
  {   num[a]++;
   i=(++i)%n;
   if(i==a) break;//循环一圈了,打断
   
  }

  j=i%n;//找到第一个不是w的节点,并记录在j中

        if(beads[i]=='b')
  {
   while(beads[i]!='r')//找到第一个r节点
   {   num[a]++;
       i=(++i)%n;
      if(i==a) break;
    
   }
          
   while(beads[i]!='b')
   {  
    if(i==a) break;
    i=(++i)%n;
    num[a]++;
   }
  }

  if(beads[j]=='r')
  {
   while(beads[j]!='b')
   {    num[a]++;
    j=(++j)%n;
    if(j==a) break;
    
   }
           
   while(beads[j]!='r')
   {  
    if(j==a) break;
    j=(++j)%n;
    num[a]++;
   }

  }
 }
 if(beads[a]=='b')
 {
  i=a;
 
  while(beads[i]!='r')
  {   num[a]++;
   i=(++i)%n;
   if(i==a) break;
   
  }
     
  while(beads[i]!='b')
  { 
   if(i==a) break;
   i=(++i)%n;
   
   num[a]++;
  }
 }
 if(beads[a]=='r')
 {
  i=a;
  
  while(beads[i]!='b')
  {   num[a]++;
   i=(++i)%n;
   if(i==a) break;
   
  }        
  while(beads[i]!='r')
  { 
   if(i==a) break;
   i=(++i)%n;
   num[a]++;
  }
 }
 return num[a];
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值