POJ1118,Lining Up,暴力过的,hash什么的只能仰慕

Lining Up

Description


"How am I ever going to solve this problem?" said the pilot. 
Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 
Your program has to be efficient! 


Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.


Output

output one integer for each input case ,representing the largest number of points that all lie on one line.


Sample Input

5
1 1
2 2
3 3
9 10
10 11
0


Sample Output

3


分析:

题意是给你若干个点,求出在一条直线上最多有多少点。

看到discuss里有什么hash之类的,听都没听说过我就不乱说了。

不过代码短,看着舒服= =。


code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define MAX 700
using namespace std;
typedef struct point
{
    int x,y;
}point;
point p[MAX+5];
int main()
{
    int n,i,j,num,tmp;
    while(scanf("%d",&n),n)
    {
        num=0;
        for(i=0;i<n;i++)
            scanf("%d %d",&p[i].x,&p[i].y);
        for(i=0;i<n;i++)
            for(j=i+1;j<n;j++)
            {
                tmp=0;
                for(int k=j+1;k<n;k++)                       //直接从j+1开始
                if((p[i].x-p[k].x)*(p[j].y-p[k].y)==(p[j].x-p[k].x)*(p[i].y-p[k].y))
                    tmp++;
                if(tmp>num) num=tmp;
            }
        num+=2;
        printf("%d\n",num);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值