POJ1562,Oil Deposits,dfs+bfs,这几天有做东西,没写博客= =

Oil Deposits

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

分析:

题目不难,主要用来熟悉深搜广搜...


code:

//广搜
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#define MAX 100
using namespace std;
char region[MAX+5][MAX+5];
int vis[MAX+5][MAX+5];
typedef struct node
{
    int i,j;
}node;
node que[MAX+5];
void bfs(int i,int j,int m,int n)
{
    int front=0,rear=1,tmpi,tmpj,a,b;
    que[0].i=i;
    que[0].j=j;
    vis[i][j]=1;
    while(front<rear)
    {
        front++;
        for(a=-1;a<2;a++)
        for(b=-1;b<2;b++)
        {
            tmpi=que[front-1].i+a;
            tmpj=que[front-1].j+b;
            if(!a&&!b) continue;
            if(region[tmpi][tmpj]=='@'&&tmpi<m&&tmpi>=0&&tmpj<n&&tmpj>=0&&!vis[tmpi][tmpj])
            {
                que[rear].i=tmpi;
                que[rear].j=tmpj;
                rear++;
                vis[tmpi][tmpj]=1;
            }
        }
    }
}
int main()
{
    freopen("input.txt","r",stdin);
    int m,n,i,j,pocket=0;
    while(scanf("%d %d",&m,&n),m||n)
    {
        memset(region,'*',sizeof(region));
        memset(vis,0,sizeof(vis));
        pocket=0;
        for(i=0;i<m;i++)
            scanf("%s",region+i);
        for(i=0;i<m;i++)
        for(j=0;j<n;j++)
        if(region[i][j]=='@'&&!vis[i][j])
        {
            pocket++;
            bfs(i,j,m,n);
        }
        printf("%d\n",pocket);
    }
    return 0;
}


//深搜
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define MAX 100
using namespace std;
char region[MAX+5][MAX+5];
int vis[MAX+5][MAX+5];
void dfs(int x,int y)
{
    if(region[x][y]=='*'||vis[x][y]) return;
    vis[x][y]=1;
    dfs(x-1,y-1);dfs(x-1,y);dfs(x-1,y+1);
    dfs(x,y-1);             dfs(x,y+1);
    dfs(x+1,y-1);dfs(x+1,y);dfs(x+1,y+1);
}
int main()
{
    int m,n,i,j,pocket=0;
    char s[MAX+5];
    while(scanf("%d %d",&m,&n),m||n)
    {
        memset(region,'*',sizeof(region));
        memset(vis,0,sizeof(vis));
        pocket=0;
        for(i=0;i<m;i++)
        {
            scanf("%s",s);
            for(j=0;j<n;j++)
                region[i+1][j+1]=s[j];
        }
        for(i=1;i<=m;i++)
        for(j=1;j<=n;j++)
        if(!vis[i][j]&®ion[i][j]=='@')
        {
            pocket++;
            dfs(i,j);
        }
        printf("%d\n",pocket);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
GeoPandas是一个开源的Python库,旨在简化地理空间数据的处理和分析。它结合了Pandas和Shapely的能力,为Python用户提供了一个强大而灵活的工具来处理地理空间数据。以下是关于GeoPandas的详细介绍: 一、GeoPandas的基本概念 1. 定义 GeoPandas是建立在Pandas和Shapely之上的一个Python库,用于处理和分析地理空间数据。 它扩展了Pandas的DataFrame和Series数据结构,允许在其中存储和操作地理空间几何图形。 2. 核心数据结构 GeoDataFrame:GeoPandas的核心数据结构,是Pandas DataFrame的扩展。它包含一个或多个列,其中至少一列是几何列(geometry column),用于存储地理空间几何图形(如点、线、多边形等)。 GeoSeries:GeoPandas中的另一个重要数据结构,类似于Pandas的Series,但用于存储几何图形序列。 二、GeoPandas的功能特性 1. 读取和写入多种地理空间数据格式 GeoPandas支持读取和写入多种常见的地理空间数据格式,包括Shapefile、GeoJSON、PostGIS、KML等。这使得用户可以轻松地从各种数据源中加载地理空间数据,并将处理后的数据保存为所需的格式。 2. 地理空间几何图形的创建、编辑和分析 GeoPandas允许用户创建、编辑和分析地理空间几何图形,包括点、线、多边形等。它提供了丰富的空间操作函数,如缓冲区分析、交集、并集、差集等,使得用户可以方便地进行地理空间数据分析。 3. 数据可视化 GeoPandas内置了数据可视化功能,可以绘制地理空间数据的地图。用户可以使用matplotlib等库来进一步定制地图的样式和布局。 4. 空间连接和空间索引 GeoPandas支持空间连接操作,可以将两个GeoDataFrame按照空间关系(如相交、包含等)进行连接。此外,它还支持空间索引,可以提高地理空间数据查询的效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值