P1001 A+B Format

P1001 A+B Format


原题
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where 1 0 − 6 ≤ a , b ⩽ 1 0 6 10^{-6}\leq a,b\leqslant 10^{6} 106a,b106.The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目链接: https://pintia.cn/problem-sets/994805342720868352/problems/994805528788582400

题目的中文意思:
题目的大概意思是计算出两个数的和然后将其结果每隔三位加以逗号的形式输出出来。

代码实现:

#include <stdio.h>
#include <iostream>
#include <stack>
using namespace std;

//用标准化的形式输出两个数之和
int main()
{
	stack<char> st;
	long int a, b,sum;
	scanf("%ld %ld", &a, &b);
	sum = a + b;
	int i = 0; //记录放入栈中的实际元素数
	if (sum == 0) printf("0\n");
	else
	{
		if (sum < 0)
		{
			printf("-");
			sum = -sum;
		}
		int i = 0;//记录实际存储的数字个数
		while (sum!=0)
		{
			st.push(sum % 10+'0');
			i++;
			if (i % 3 == 0) st.push(',');
			sum /= 10;
		}
	}
	//输出栈中的所有数据
	//处理最后一位刚好被三整除的异常
	if (!st.empty()&&st.top() == ',') st.pop();
	while (!st.empty())
	{
		printf("%c",st.top());
		st.pop();
	}
	//system("pause");
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值