HDU 5437 Alisha’s Party(2015ACM长春赛区网络赛+优先队列)

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1953 Accepted Submission(s): 529


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the nth person to enter her castle is.

Input
The first line of the input gives the number of test cases, T , where 1T15 .

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000 . The door would open m times before all Alisha’s friends arrive where 0mk . Alisha will have q queries where 1q100 .

The ith of the following k lines gives a string Bi , which consists of no more than 200 English characters, and an integer vi , 1vi108 , separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi .

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqth friends to enter her castle.

Note: there will be at most two test cases containing n>10000 .

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input
  
  
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3

Sample Output
  
  
Sorey Lailah Rose

Source

/*这题做了好久...题意没理解好  
首先优先队列里的比较函数的大小写符号要写反..然后每个查询要先存入,
再操作..并不是按顺序来的...(缺乏做题经验) 
 如果按之前的做法  应该是总体输入存入后 排下序搞
 发现有人题解用enter[i]数组存第i个人来了可以进几个人  发现更好
 所以改了下
 然后操作就是  到第i个人时,都进优先队列,然后进
 Min(队列里的人数,可以进的人数)   就好了... 
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
#include <string>
#include <queue> 
using namespace std;
const int N=150000+10;
struct Node{
    int v,id;
}node[N],tmp;
char name[N+1][200+5];
int enter[N];  //第i人时可以进的人数 
struct cmp{
	bool operator()(Node a,Node b){
    if(a.v==b.v)
        return a.id>b.id;
    return a.v<b.v;
}
};
int re[N+1];  //记录结果位置的id 
priority_queue<Node,vector<Node>,cmp> q;
int main(){
    int t,k,m,p,i,now,j,a,b,z;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d",&k,&m,&p);
        for(i=0;i<k;i++){
            scanf("%s%d",name[i],&node[i].v);
            node[i].id=i;
            enter[i]=0;
        }               
        for(i=0;i<m;i++){
           scanf("%d%d",&a,&b);
           enter[a-1]+=b; 
} 
        int x=0;  //记录结果的下标  
        for(now=0;now<k;now++){
             //前第a个人 
            q.push(node[now]); 
			if(enter[now]==0)
		     	continue; 
        	for(j=0;!q.empty()&&j<enter[now];j++){   //可以进b人 
            Node tmp=q.top();
               q.pop();         
              re[x++]=tmp.id;
        }
		}   
		while(!q.empty()){
			Node tmp=q.top();
               q.pop();         
              re[x++]=tmp.id;
		} 		 
		
        while(p--){
            scanf("%d",&i);
            printf("%s",name[re[i-1]]);
            if(p!=0)
              printf(" ");
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值