HDU 2824 The Euler function(欧拉函数)

The Euler function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4482 Accepted Submission(s): 1859


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).

Output
Output the result of (a)+ (a+1)+....+ (b)

Sample Input
  
  
3 100

Sample Output
  
  
3042
#include <iostream>
#include <cstdio>
using namespace std;
const int N=3000000+10;
long long phi[N];
inline void Init(){
	long long i,j;
	phi[0]=0;
	for(i=1;i<N;i++)  phi[i]=i;
	for(i=2;i<N;i+=2)  phi[i]/=2;
	for(i=3;i<N;i+=2) 
	if(phi[i]==i){
		for(j=i;j<N;j+=i)
	   phi[j]=phi[j]/i*(i-1);
	}
}
int main(){
	Init();
	int a,b,i;
	long long sum;
	while(cin>>a>>b){
		sum=0;
		for(i=a;i<=b;i++)
		 sum+=phi[i];
		cout<<sum<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值