[PAT甲级] 1009 Product of Polynomials (25)

题目:

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ … NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6


题目简介:计算两个多项式的乘积,先输出项数,接着按“ 指数 系数“的格式输出每一项。乘积结果中相同指数项要合并,系数为0的项要去除。

#include <iostream>
#include <stdlib.h>
#include <algorithm> 
using namespace std;
typedef struct pair{
    double co;
    int ex;
}P;
bool compare(P p1, P p2){
    return p1.ex > p2.ex;
}
int main() {
    int N, M, i, j, k;
    P p1[10], p2[10], p3[100];
    scanf("%d", &N);
    for(i = 0; i < N; i++)
        scanf("%d%lf", &p1[i].ex, &p1[i].co);
    scanf("%d", &M);
    for(i = k = 0; i < M; i++){
        scanf("%d%lf", &p2[i].ex, &p2[i].co);
        for(j = 0 ; j < N; j++){
            p3[k].co = p1[j].co * p2[i].co;
            p3[k].ex = p1[j].ex + p2[i].ex;
            k++;
        }
    }
    sort(p3, p3 + k, compare);
    for(i = j = 0; i < k; i++, j++){
        P tmp = p3[i];
        while(p3[i + 1].ex == p3[i].ex){
            i++;
            tmp.co += p3[i].co;
        }
        p3[j] = tmp;
        if(tmp.co == 0)
            j--;
    }
    printf("%d", j);
    for(i = 0; i < j; i++)
        printf(" %d %.1lf", p3[i].ex, p3[i].co);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值