浙大PTA 7-5 Tree Traversals Again (25point(s))

7-5 Tree Traversals Again (25point(s))

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

在这里插入图片描述

Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

#include <iostream>
#include<bits/stdc++.h>
using namespace std;

int pre[35];
int in[35];
int post[35];

void solve(int preL, int inL, int postL, int n)
{   /*preL:先序遍历最左边元素的位置
    inL:中序遍历最左边元素的位置
    preL:后序遍历最左边元素的位置
    */
    if(n == 0)return;
    else if(n == 1){post[postL] = pre[preL]; return;}
    int root = pre[preL];
    post[postL + n - 1] = root;
    int i;
    for( i = 0; i < n; i++)
        if(in[inL + i] == root)break;
    int L = i;int R = n - L - 1;
    solve(preL + 1, inL, postL, L);
    solve(preL + L + 1, inL + L + 1, postL + L, R);
}

int main()
{
    int n;
    stack<int>s;
    scanf("%d", &n);
    getchar();
    int cnt1 = 0, cnt2 = 0;
    for(int i = 0; i < 2 * n; i++)
    {
        string str;
        cin>>str;
        if(str == "Push"){
            int e;
            scanf("%d", &e);
            pre[cnt1++] = e;
            s.push(e);
            getchar();
        }
        else{
            in[cnt2++] = s.top();
            s.pop();
            getchar();
        }
    }
    solve(0, 0, 0, n);
    for(int i = 0; i < n; i++){
        if(i == 0){}
        else
            printf(" ");
        printf("%d", post[i]);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值