1153 Decode Registration Card of PAT (25分)

这是一个关于处理学生准考证号和成绩的程序设计问题。给定一组包含考试等级、考场号、考试日期和考号的准考证号,以及每个学生的成绩,程序需要根据不同的查询类型返回相应结果。查询类型包括:1)按考试等级查找并按成绩降序排列;2)统计特定考场的考生数量和总得分;3)按考试日期查询所有考场的考生人数。程序通过排序和哈希表实现高效查询,对于特定类型的查询可能需要考虑使用无序_map以避免排序导致的时间消耗。
摘要由CSDN通过智能技术生成

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

 

题目大意:

给出一组学生的准考证号,其中包含考试等级(甲乙级)、考场号、考试日期和考号以及成绩 ,给定查询条件,输出查询结果

共有三种查询条件

  1. 给出考试等级,找出该等级的考生,按照成绩降序,成绩相同则按照准考证号升序排序
  2. 给出考场号,统计该考场的考生数量和总得分
  3. 给出考试日期,查询日期下所有考场的考试人数,按人数降序,人数相同则按考场号升序输出。

 

分析:

1.按等级查询,枚举选出等级符合条件的准考证号,使用sort排序

2.按照考场查询,枚举选出匹配的学生,然后计数,求和

3.按照日期查询,用unorder_map存储(考场号,人数),这里如果使用map测试点三会超时。

unorder_map的底层是用hash实现的,是无序存储的,map底层是用红黑树实现的,是有序存储的,因此map会花更长的时间

 

#include<bits/stdc++.h>
using namespace std;
typedef struct node
{
    string info;
    int f;
} node;

typedef struct siteInfo
{
    string site;
    int num;
}Info;
bool cmp1(struct node a,struct node b)
{
    return a.f!=b.f?a.f>b.f:a.info<b.info;
}
bool cmp2(struct siteInfo a,struct siteInfo b)
{
    return a.num!=b.num?a.num>b.num:a.site<b.site;

}
int main()
{
    string s;
    int n,m,i,j,x;
    node a[10010];
    node temp;
    cin>>n>>m;
    for(i=1; i<=n; i++)
    {
        cin>>s>>x;
        temp.info=s;
        temp.f=x;
        a[i]=temp;
    }

    for(i=1; i<=m; i++)
    {
        int f=0;
        cin>>x>>s;
        printf("Case %d: %d %s\n",i,x,s.c_str());
        if(x==1)
        {
            vector<node>t;
            for(j=1; j<=n; j++)
            {
                if(a[j].info.substr(0,1)==s)
                {
                    t.push_back(a[j]);
                }
            }
            if(t.size())
            {
                f=1;
                sort(t.begin(),t.end(),cmp1);
                for(j=0; j<t.size(); j++)
                {
                    printf("%s %d\n",t[j].info.c_str(),t[j].f);
                }
            }

        }
        else if(x==2)
        {
            int num=0;
            int sum=0;
            for(j=1; j<=n; j++)
            {
                if(a[j].info.substr(1,3)==s)
                {
                    num++;
                    sum+=a[j].f;
                }
            }
            if(num!=0)
            {
                f=1;
                printf("%d %d\n",num,sum);
            }
        }
        else if(x==3)
        {
            unordered_map<string,int> M;
            vector<Info> tt;
            for(j=1; j<=n; j++)
            {
                if(a[j].info.substr(4,6)==s)
                {
                    string ta = a[j].info.substr(1,3);
                    M[ta]++;
                }
            }
            for(auto it = M.begin();it!=M.end();it++)
            {
                Info node1;
                node1.site=it->first;
                node1.num=it->second;
                tt.push_back(node1);


            }
            if(tt.size())
            {
                f=1;
                sort(tt.begin(),tt.end(),cmp2);
                for(j=0; j<tt.size(); j++)
                {
                    printf("%s %d\n",tt[j].site.c_str(),tt[j].num);
                }
            }
        }
        if(f==0)
        {
            printf("NA\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值