HDU--1003Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 209181    Accepted Submission(s): 49001


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L


AC代码:
#include <stdio.h>
int a[1000000],b[1000000];//数组a存数 数组b存后面一个的位置
int Max(int a, int b)
{
    return a > b ? a : b;
}
int main(void)
{
    int T,n,i,j;
    int begin=0;//开始位置
    int max,x,y;
    scanf("%d",&T);
    for(j=1;j<=T;j++)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        max=x=a[n-1];//假设最后一个数最大
        b[n-1] = n;//后面一个的位置初始化为最后的位置
        begin=n-1;//逆向开始  从后面往前面相加
        for(i = n-2; i >= 0; i--)
        {
            y=Max(a[i]+x,a[i]);//比较
            x=y;
            if(y==a[i]) b[i]=i+1;
            else b[i]=b[i+1];
            if(y>=max)
            {
                max=y;
                begin=i;
            }
        }
        if(j!=1)  printf("\n");//控制格式
        printf("Case %d:\n",j);
        printf("%d %d %d\n",max,begin+1,b[begin]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值