Oil Deposits

Oil Deposits

杭电OJ1241题目链接

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2

思路:
典型的DFS题目,用一个index[][]数组表示每个点所属的区块号,从一个点开始用深度搜索把和它属于同一区块的点找到并将其相应的index[][]标志设为区块号,直到将该区块内所有的点都找到,再从下一个点开始执行上面的步骤,直到所有的点都被访问。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
char p[105][105];           //储存地图
int index[105][105];        //标志,用来判断是否已遍历
int m, n;                   //地图的行列
int cnt;                    //分区的个数,初始为0

//DFS深度搜索,参数r,c所遍历的区域的横纵坐标,id所属的分区块编号
int dfs(int r, int c, int id){

    if (p[r][c] != '@' || index[r][c] != 0)     //若该点不是@或者该点已被访问过则直接返回
        return 0;
    else if(r<0 || r>=m || c<0 || c>=n)         //若该点坐标非法则直接返回
        return 0;
    else{                                       //处理该节点
        index[r][c] = id;                       //将该点设为已经访问过

       for (int i=-1; i<=1; i++){              //对该节点周围8个点进行遍历,分别访问
            for (int j=-1; j<=1; j++){
                if (i==0 && j==0)
                    continue;
                else{
                    dfs(r+i, c+j, id);
                }
            }
        }
    }
    return 1;
}
int main()
{
    while(scanf("%d%d", &m, &n) == 2 && m && n){
        for (int i=0; i<m; i++){
            scanf("%s", p[i]);
        }

        //对每组输入初始化
        cnt = 0;
        memset(index, 0, sizeof(index));

    for (int i=0; i<m; i++){
        for (int j=0; j<n; j++){

            if (p[i][j] == '@' && index[i][j] == 0){        //从第一个点开始遍历
                dfs(i, j, ++cnt);
            }
        }
    }
    printf("%d\n", cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值