Switch Game

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

Input

Each test case contains only a number n ( 0< n<= 10^5) in a line. 

Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

Sample Input

1
5

Sample Output

1
0
/*题意要理解清楚,这就是开关灯问题,刚开始输出的数代表操作次数和最后问题中的第几个灯泡
这个可以每次操作都是当前第几个灯泡的倍数进行操作,每次操作都是将当前状态变为相反
状态*/ 
/*所有灯刚开始是都是熄灭的,依次从1到n标号,第一次把所有是一的倍
数的灯变为相反的状态,第二次把所有是二的倍数的灯变为相反的状态
,第三次把所有是三的倍数的灯变为相反的状态,以此类推,问第n个灯
的明暗情况?

思路:第n次之后,第n个灯的状态不会再改变!!!*/
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
      int n;
      while(cin>>n)
      {
      	int sum=0;
      	for(int i=1;i<=n;i++)
      	{
      		if(n%i==0)
      		{
      			sum++;
			}
		}
		if(sum%2==0)
		{
			cout<<0<<endl;
		}
		else
		{
			cout<<1<<endl;
		} 
	  }
	  return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值