[递归和栈] Boolean Expressions

描述

The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next:

Expression: ( V | V ) & F & ( F | V )


where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed.

To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file.

输入

The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown.

The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below.

输出

For each test expression, print "Expression " followed by its sequence number, ": ", and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line.

Use the same format as that shown in the sample output shown below.

样例输入

( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))

样例输出

Expression 1: F
Expression 2: V
Expression 3: V
解题分析

其实这种表达式的求值可以用两个栈的做法来做,而且某种程度上也更符合思维的一个逻辑。首先,我们定义两个栈来辅助我们表达式的计算,一个栈用来存储数值,一个栈用来存储运算符。接着,我们开始遍历整个表达式,如果遇见了正括号,我们往运算符的栈里扔一个0,如果遇见了反括号,我们先判断栈里有没有元素以及上一个运算符是不是0(如果是0说明我们在上面的运算过程中没有&或者|运算需要我们去处理,所以不用calculate),否则调用calculate函数不断地计算括号里面的值。最后,我们重新insert一下防止括号外边有一些!运算符。当我们遇见"!"的时候,往符号运算符栈里面扔3,当我们遇见&的时候,这个时候我们可以先计算一下同级的&运算符了,然后再往符号运算符里面扔2,同理当我们遇见|的时候,这个时候我们可以先计算一下同级的|运算符了,然后再往符号运算符里面扔1,遇见'F'和'V'的时候,直接往值运算栈里面扔0/1即可。在这样一个双栈过程中,我们确保了!运算符优先级最高,&第二,|第三。最后,我们看看符号运算栈里还有没有元素,如果有的话继续计算即可。

代码实现
#include <iostream>
#define MAXN 110
using namespace std;
int val[MAXN],op[MAXN],vtop=0,otop=0;

void insert(int x){
	while(otop && op[otop-1]==3){
		x=!x; otop--;
	}
	val[vtop++]=x;
}

void calculate(){
	int a=val[--vtop];
	int b=val[--vtop];
	int c=op[--otop];
	if(c==2) insert(a&b);
	else insert(a|b);
}

int main(){
	string s;
	int t=0;
	while(getline(cin,s)){
		t++;
		otop=vtop=0;
		int lens=s.size();
		for(int i=0;i<lens;i++){
			switch (s[i]) {
			case '(':
				op[otop++]=0;
				break;
			case ')':
				while(otop && op[otop-1]!=0) calculate();
				--otop;
				insert(val[--vtop]);
				break;
			case '!':
				op[otop++]=3;
				break;
			case '&':
				while(otop && op[otop-1]>=2) calculate();
				op[otop++]=2;
				break;
			case '|':
				while(otop && op[otop-1]>=1) calculate();
				op[otop++]=1;
				break;
			case 'V':
				insert(1);
				break;
			case 'F':
				insert(0);
				break;
			default:
				break;
			}
		}
		while(otop) calculate();
		cout<<"Expression "<<t<<": "<<(val[0]?'V':'F')<<endl;
	}
	return 0;
}

  • 23
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值