HDU-1372 Knight Moves (BFS搜索入门)

HDU-1372 Knight Moves (BFS搜索入门)

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the “difficult” part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (ah) representing the column and a digit (1-8) representing the row on the chessboard.
Output
For each test case, print one line saying “To get from xx to yy takes n knight moves.”.
Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

其实就是一个马走日字的问题,我把a-h转换成1-8,字符1-8转换成数字1-8,不转换判断条件需要重新写一下

移动方向示意图如下:

可走的方向

代码如下:
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
struct node{int x;int y;int step;};
int sx,sy,ex,ey;
int book[10][10];
int dx[8]={-2,-2,-1,-1,1,1,2,2};
int dy[8]={-1,1,-2,2,-2,2,-1,1};

int bfs(int x,int y){
	node s,now,next;//当前节点,下一节点
	s.x=x;
	s.y=y;
	s.step=0;
	book[x][y]=1;//标记走过
	queue<node>qu;
	qu.push(s);//把起点放入队列
	while(!qu.empty()){
		now=qu.front();//返回第一个元素
		qu.pop();//删除第一个元素
		if(now.x==ex&&now.y==ey){
			return now.step;
		}
		for(int i=0;i<8;i++){//类似于dfs
			next.x=now.x+dx[i];
			next.y=now.y+dy[i];
			next.step=now.step;//多了一个step的累加
			if(book[next.x][next.y]==0&&next.x>=1&&next.x<=8&&next.y>=1&&next.y<=8){
				book[next.x][next.y]=1;//标记走过
				next.step+=1;
				qu.push(next);//放到队列里
			}
		}	
	}
}

int main()
{
	char str1[4],str2[4];
	int sum;
	while(~scanf("%s %s",str1,str2)){
		memset(book,0,sizeof(book));
		sx=str1[0]-'a'+1;//x属于[1,8]
		sy=str1[1]-'0';//注意这里!!输入的数字是字符型的,先转换一下
		ex=str2[0]-'a'+1;
		ey=str2[1]-'0';//y属于[1,8]
		sum=bfs(sx,sy);//从起点搜索 返回到终点的步数
		printf("To get from %s to %s takes %d knight moves.\n",str1,str2,sum);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值