ayit 第九周训练 a题

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. Of course you know that it is vice versa. So you offer him to write a program that solves the ”difficult” part. Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. I

nput The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a..h) representing the column and a digit (1..8) representing the row on the chessboard

. Output For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.

Sample Input

e2 e4

a1 b2

b2 c3

a1 h8

a1 h7

h8 a1

b1 c3

f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.

To get from a1 to b2 takes 4 knight moves.

To get from b2 to c3 takes 2 knight moves.

To get from a1 to h8 takes 6 knight moves

. To get from a1 to h7 takes 5 knight moves.

To get from h8 to a1 takes 6 knight moves.

To get from b1 to c3 takes 1 knight moves.

To get from f6 to f6 takes 0 knight moves.

 

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
	int x;
	int y;
	int step;
}u,v;
int book[110][110],x1,y1;
int to[8][2]={-2,1,-1,2,1,2,2,1,2,-1,1,-2,-1,-2,-2,-1};
int ff(int x,int y)
{
    int i;
    if(x==x1&&y==y1)
        return 0;
    queue<node>q;
    u.x=x;
    u.y=y;
    u.step=0;
    book[x][y]=1;
    q.push(u);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        for(i=0;i<8;i++)
        {
            v.x=u.x+to[i][0];
            v.y=u.y+to[i][1];
            v.step=u.step+1;
            if(v.x==x1&&v.y==y1)
                return v.step;
            if(book[v.x][v.y]==0&&v.x>=1&&v.x<=8&&v.y>=1&&v.y<=8)
            {
                book[v.x][v.y]=1;
                q.push(v);
            }
        }
    }
    return 0;
}
int main()
{
    char a[10],b[10];
    while(~scanf("%s %s",a,b))
    {
        int x,y,s;
        memset(book,0,sizeof(book));
        x=a[0]-'a'+1;
         y=a[1]-'0';
          x1=b[0]-'a' +1;
            y1=b[1] -'0';
            s=ff(x,y);
        printf("To get from %s to %s takes %d knight moves.\n",a,b,s);
    }
    return 0;
}

题意  给出骑士的骑士位置和目标位置,计算骑士要走多少步

思路    骑士最多可以朝八个方向移动,那么就朝8个方向进行搜索(广搜题用到queue队列)

         和以前做的马走日很像

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值