STL练习(vector, string, map, sort)

问题 D: Ananagrams
时间限制: 1 Sec 内存限制: 128 MB

题目描述
Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.
Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.
Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

输入
Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.
输出
Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.
样例输入 Copy
ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries

样例输出 Copy
Disk
NotE
derail
drIed
eye
ladder
soon

个人感觉用STL非常方便的一道题, 思路参考https://www.cnblogs.com/Fy1999/p/9348256.html
大佬%%%~

题意: 给定一堆单词, 可通过重新排列变成一样的单词都看作同一个单词, 要求将真正不同的单词按字典序输出.

思路: 先用vector将每一个单词s存起来, 再将每个单词统一化成小写/大写字母进行排序, 用map在原单词s与处理后单词tmp间建立映射, 再用另一个map建立处理后单词tmp与其出现次数的映射, 最后用sort将原单词按字典序排序, 再遍历vector中的原单词, 若其只出现一次, 则输出. 代码如下:

#pragma comment(linker, "/STACK:102400000,102400000")
#pragma GCC optimize(3, "Ofast", "inline")
#pragma GCC optimize(2)
#include <bits/stdc++.h>
#define RE register int
#define INF 0x3f3f3f3f
#define EPS 1e-8
using namespace std;
typedef unsigned long long ull;
typedef long long ll;
typedef pair<int,int> P;
const double Pi = acos(-1);
const int mod = 1e9 + 7;
const int N = 1e2 + 10;
const ll inf = 1e15;
map<string,string> mp1;
map<string,int> mp2;
vector<string> v;
string s;

int main() {
//    freopen("test.txt", "r", stdin);
    ios::sync_with_stdio(false);
    cin.tie(0); cout.tie(0);
    while (cin >> s && s != "#") {
        v.push_back(s); string tmp = s;
        for (auto & i : s) i = tolower(i);
        stable_sort(s.begin(), s.end());
        mp1[tmp] = s; mp2[s]++;
    } stable_sort(v.begin(), v.end());
    for (auto i : v) if (mp2[mp1[i]] == 1) cout << i << endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值