poj 3211 结构体-分组一维dp

Washing Clothes
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 9462 Accepted: 3031

Description

Dearboy was so busy recently that now he has piles of clothes to wash. Luckily, he has a beautiful and hard-working girlfriend to help him. The clothes are in varieties of colors but each piece of them can be seen as of only one color. In order to prevent the clothes from getting dyed in mixed colors, Dearboy and his girlfriend have to finish washing all clothes of one color before going on to those of another color.

From experience Dearboy knows how long each piece of clothes takes one person to wash. Each piece will be washed by either Dearboy or his girlfriend but not both of them. The couple can wash two pieces simultaneously. What is the shortest possible time they need to finish the job?

Input

The input contains several test cases. Each test case begins with a line of two positive integers M and N (M < 10, N < 100), which are the numbers of colors and of clothes. The next line contains M strings which are not longer than 10 characters and do not contain spaces, which the names of the colors. Then follow N lines describing the clothes. Each of these lines contains the time to wash some piece of the clothes (less than 1,000) and its color. Two zeroes follow the last test case.

Output

For each test case output on a separate line the time the couple needs for washing.

Sample Input

3 4
red blue yellow
2 red
3 blue
4 blue
6 red
0 0

Sample Output

10

题意:

 俩人洗衣服。。你一件我一件

必须俩人把同一个色的洗完才能洗下一个颜色的。问最小时间是多少



题解

有n个颜色的,所以整个背包问题循环n次

分别对于每一种颜色进行 0 1 背包处理

其中一个人洗衣服的时间最大为总时间的一半




#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int m,n;
int dp[1000005];

struct COLOR{
    char color[12];
    int time[105];
    int num;
    int sum;
}one_of_color[12];

void input()
{
    for(int i=0;i<m;i++){
        scanf("%s",one_of_color[i].color);
        one_of_color[i].sum=0;
        one_of_color[i].num=0;
    }

    int t;
    char temp[15];
    for(int i=0;i<n;i++){
        scanf("%d%s",&t,temp);

        for(int j=0;j<m;j++){
            if(!strcmp(temp,one_of_color[j].color)){
                one_of_color[j].time[one_of_color[j].num++]=t;
                one_of_color[j].sum+=t;
                break;
            }
        }
    }
}

void deal()
{
    int ans=0;
    for(int i=0;i<m;i++){
        memset(dp,0,sizeof(dp));
        int temp=one_of_color[i].sum/2;

        for(int j=0;j<one_of_color[i].num;j++)
            for(int k=temp;k>=one_of_color[i].time[j];k--)
                dp[k]=max(dp[k],dp[k-one_of_color[i].time[j]]+one_of_color[i].time[j]);

        ans=ans+one_of_color[i].sum-dp[temp];
    }
    printf("%d\n",ans);
}

int main()
{
    while(scanf("%d%d",&m,&n),m&&n){
        input();
        deal();
    }
     return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值