poj 1572 kmp

Automatic Editing
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1386 Accepted: 643

Description

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below. 
        Rule  Find  Replace-by 

         1.ban      bab 

         2.baba     be 

         3.ana      any 

         4.ba b     hind the g 

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant. 

For example, suppose we start with the line 

banana boat 

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once. 
     Before      After 

     banana boat babana boat 

     babana boat bababa boat 

     bababa boat beba boat 

     beba boat   behind the goat 

Input

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit.

Output

For each test case, output a line containing the final edited text. 

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long. 

The first test case in the sample input below corresponds to the example shown above. 

Sample Input

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Sample Output

behind the goat
shoe or shop



题意:就是查找与替换

题解:用kmp查找在哪一个地方,两个字符串开始相同


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n;
char str1[12][90];
char str2[12][90];
char str[260];

int next[260];
char temp_str1[260];
char temp_str2[260];
//---------------------------------------------------//
void getnext(char *ch){
    int len=strlen(ch);
    int k=-1,j=0;

    while(j<len)
    {
        if(k==-1||ch[j]==ch[k])
            next[++j]=++k;
        else
            k=next[k];
    }
}
//---------------------------------------------------//
int kmp(char *ch,char *ch1)
{
    int i=0,j=0;
    int len=strlen(ch);
    int len1=strlen(ch1);

    while(i<len&&j<len1)
    {
        if(j==-1||ch[i]==ch1[j])
            i++,j++;
        else
            j=next[j];
    }

    if(j>=len1)
        return i-len1;
    else
        return -1;
}
//---------------------------------------------------//
int main()
{
    while(scanf("%d",&n),n)
    {
        getchar();//***
        for(int i=0;i<n;i++){
            gets(str1[i]);
            gets(str2[i]);
        }
        gets(str);


        for(int i=0;i<n;i++){
            memset(next,-1,sizeof(next));
            getnext(str1[i]);
            int p;
            int len1=strlen(str1[i]);

            while((p=kmp(str,str1[i]))!=-1)
            {
                int len=strlen(str);
//---------------------前一段----------------------------//
                int j;
                for(j=0;j<p;j++)
                    temp_str1[j]=str[j];
                temp_str1[j]='\0';
//---------------------后一段----------------------------//
                int k=0;
                for(int j=p+len1;j<len;j++)
                    temp_str2[k++]=str[j];
                temp_str2[k]='\0';
//---------------------衔接字符串------------------------//
                strcpy(str,temp_str1);
                strcat(str,str2[i]);
                strcat(str,temp_str2);
            }
        }

        printf("%s\n",str);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值