poj 1780 欧拉回路求解

60 篇文章 0 订阅

Code
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2520 Accepted: 881

Description

KEY Inc., the leading company in security hardware, has developed a new kind of safe. To unlock it, you don't need a key but you are required to enter the correct n-digit code on a keypad (as if this were something new!). There are several models available, from toy safes for children (with a 2-digit code) to the military version (with a 6-digit code). 

The safe will open as soon as the last digit of the correct code is entered. There is no "enter" key. When you enter more than n digits, only the last n digits are significant. For example (in the 4-digit version), if the correct code is 4567, and you plan to enter the digit sequence 1234567890, the door will open as soon as you press the 7 key. 

The software to create this effect is rather simple. In the n-digit version the safe is always in one of 10 n-1 internal states. The current state of the safe simply represents the last n-1 digits that have been entered. One of these states (in the example above, state 456) is marked as the unlocked state. If the safe is in the unlocked state and then the right key (in the example above, 7) is pressed, the door opens. Otherwise the safe shifts to the corresponding new state. For example, if the safe is in state 456 and then you press 8, the safe goes into state 568. 

A trivial strategy to open the safe is to enter all possible codes one after the other. In the worst case, however, this will require n * 10 n keystrokes. By choosing a good digit sequence it is possible to open the safe in at most 10 n + n - 1 keystrokes. All you have to do is to find a digit sequence that contains all n-digit sequences exactly once. KEY Inc. claims that for the military version (n=6) the fastest computers available today would need billions of years to find such a sequence - but apparently they don't know what some programmers are capable of...

Input

The input contains several test cases. Every test case is specified by an integer n. You may assume that 1<=n<=6. The last test case is followed by a zero.

Output

For each test case specified by n output a line containing a sequence of 10 n + n - 1 digits that contains each n-digit sequence exactly once.

Sample Input

1
2
0

Sample Output

0123456789
00102030405060708091121314151617181922324252627282933435363738394454647484955657585966768697787988990



题意:

求出一个长度为10^n+n-1的序列,其中包含了所有的n位数(一共10^n个数,从00000(n个0)~10^n-1)

题解:

模拟栈记录所有数字

利用cnt数组,记录所有数字的前缀(除了最后一位数字)的最后一位数字出现次数

在下面写的搜索函数中,mod这个值就是解决问题的关键

这个代码还真不好解释,就是类似于二进制的处理问题的思维,这里只是普通的十进制而已



注意:

const int MAXN=1e5+10;是整数

#define MAXN 1e5+10是double类型数据




#include<math.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int MAXN=1e5+10;
int cnt[MAXN];
int ans[MAXN*10];
int stack[MAXN*10];

int top,mod;
void Search(int v)
{
    while(cnt[v]<10)
    {
        int temp=v*10+cnt[v];
        cnt[v]++;
        stack[top++]=temp;
        v=temp%mod;

    }
}

int main()
{
    int n;
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n),n)
    {
        int p=0;
        top=0;
        mod=pow(10.0,n-1);
        memset(cnt,0,sizeof(cnt));
        Search(0);
        while(top)
        {
            int v=stack[--top];
            ans[p++]=v%10;
            v/=10;
            Search(v);
        }

        for(int i=1;i<n;i++)
            printf("0");
        while(p)
            printf("%d",ans[--p]);
        puts("");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值