D - Feel Good (前缀和 单调栈)

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.
Input
The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10  6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output
Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.
Sample Input
6
3 1 6 4 5 2
Sample Output
60

3 5

思路 : 对每一个数以它作最小值都能左右延伸得到一个区间,用栈来寻找每个位置的左右边界,同时为

了节省时间用scanf 而不用 cin ,外加前缀和求部分数列和。

#include <stdio.h>
#include <iostream>
#include <queue>
#include <stack>
#include <cstring>
using namespace std;

typedef long long ll;

const int maxn = 100100;

ll a[maxn]; // 存数据
ll l[maxn]; //  记录每个位置左边界
ll r[maxn]; // 记录每个位置右边界
ll sum[maxn]; //前缀和求区间和

int main()
{
    ll n;
    scanf("%lld",&n);//cin 会超时
    stack <ll> s;
    for(int i = 1; i <= n; i++)
    {
        scanf("%lld",&a[i]);
        sum[i] = sum[i-1] + a[i];
    }
    for(int i = 1; i <= n; i++) //确定左边界
    {
        while(!s.empty() && a[i] <= a[s.top()]) s.pop();
        l[i] = s.empty()? 1 : s.top() + 1;
        s.push(i);
    }

    stack <ll> s1;
    for(int i = n; i > 0; i--) //确定右边界
    {
        while(!s1.empty() && a[i] <= a[s1.top()]) s1.pop();
        r[i] = s1.empty()? n : s1.top() - 1;
        s1.push(i);
    }
    ll ans = 0;
    ll sum_,index = 1;//初始化不能少
    for(int i = 1; i <= n; i++)
    {
        sum_ = sum[r[i]] - sum[l[i]-1];
        if(sum_ * a[i] > ans) ans = sum_*a[i],index = i;
    }
    cout << ans << endl << l[index] << " " << r[index] <<endl;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值