D - Feel Good

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people’s memories about some period of life.

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.
Input
The first line of the input contains n - the number of days of Bill’s life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, … an ranging from 0 to 10 6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output
Print the greatest value of some period of Bill’s life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill’s life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.
Sample Input
6
3 1 6 4 5 2
Sample Output
60
3 5
单调栈问题
思路:向左向右各扫一遍
记录l[],r[],分别是第i个元素的最左端和最右端
栈中记录的是序号
向左扫时,如果当前的数a[i]比a[s.top()]小,则可以pop()掉栈顶的元素,因为如果后面的数比a[i]小的话,则完全可以走a[i]的路,如果比a[i]大的话,则连a【i】的路都走不了。
栈的用法之一就是:扫描某个元素的左边右边

#include<iostream>
#include<cstdio>
#include<stack>
using namespace std;
int l[110000],r[110000],a[110000];
long long sum[110000];
int main ()
{
   int n;
   long long maxx=0,he=0;
   while(~scanf("%d",&n))
   {
          int i;
          sum[0]=0;
   for(i=1;i<=n;i++)
   {
     scanf("%d",&a[i]);
      sum[i]=a[i]+sum[i-1];
      //printf("%d\n",sum[i]);
   }

   stack <int> s;
   s.push(1);
   for(i=1;i<=n;i++)
   {
       if(a[s.top()]>=a[i])
       {
           while(s.size()!=0&&a[s.top()]>=a[i])
            s.pop();
           if(s.size()==0)
            l[i]=1;
           else
           {
               l[i]=s.top()+1;
           }
           s.push(i);
       }
       else
       {
           l[i]=i;
           s.push(i);
       }
   }
   while(s.size()!=0)
   {
       s.pop();
   }
   s.push(n);
   for(i=n;i>0;i--)
   {
       if(a[s.top()]>a[i])
       {
           while(s.size()!=0&&a[s.top()]>=a[i])
           {
                s.pop();
           }
           if(s.size()==0)
            r[i]=n;
           else
            r[i]=s.top()-1;
           s.push(i);
       }
       else
       {
           r[i]=i;
           s.push(i);
       }
   }
   while(s.size()!=0)
   {
       s.pop();
   }
   int j,aa,bb;
   maxx=0;
   he=0;
   for(i=1;i<=n;i++)
   {
       he=0;
        he=sum[r[i]]-sum[l[i]-1];
          he=he*a[i];
        if(maxx<=he)
        {
            maxx=he;
            aa=l[i];
            bb=r[i];
        }
   }
   printf("%lld\n",maxx);
   printf("%d %d\n",aa,bb);
   /*for(i=1;i<=n;i++)
    printf("%d %d\n",l[i],r[i]);*/
   }
   return 0;
}

今天又做了一遍

#include<iostream>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<stack>
using namespace std;
const int maxn=100000+100;
int a[maxn],l[maxn],r[maxn];
long long sum[maxn];
int main ()
{
	int n;
	while(~scanf("%d",&n))
	{
		sum[0]=0;
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		sum[i]=sum[i-1]+a[i];
	}
	stack<int>s;
	s.push(1);
	int i;
	for(i=1;i<=n;i++)
	{
		if(a[s.top()]>=a[i])
		{
			while(!s.empty()&&a[s.top()]>=a[i])
			{
				s.pop();
			}
			if(s.empty())
			{
				l[i]=1;
			}
			else
			{
				l[i]=s.top()+1;
			}
			s.push(i);
		}
		else
		{
			l[i]=i;
			s.push(i);
		}
	}
	while(!s.empty())
	{
		s.pop();
	}
	s.push(n);
	for(i=n;i>=1;i--)
	{
		if(a[s.top()]>a[i])
		{
			while(!s.empty()&&a[s.top()]>a[i])
			{
				s.pop();
			}
			if(s.empty())
			{
				r[i]=n;
			}
			else
			{
				r[i]=s.top()-1;
			}
			s.push(i);
		}
		else
		{
			r[i]=i;
			s.push(i);
		}
	}
	while(!s.empty())
	{
		s.pop();
	}
	long long maxx=0,cnt=0;
	int left=0,right=0;
	for(i=1;i<=n;i++)
	{
		cnt=sum[r[i]]-sum[l[i]-1];
		cnt=cnt*a[i];
		if(maxx<=cnt)
		{
			left=l[i];
			right=r[i];
			maxx=cnt;
		}
	} 
	printf("%lld\n",maxx);
	printf("%d %d\n",left,right);
	}	
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值