Skiing POJ - 3037 (Dijkstra)

Bessie and the rest of Farmer John's cows are taking a trip this winter to go skiing. One day Bessie finds herself at the top left corner of an R (1 <= R <= 100) by C (1 <= C <= 100) grid of elevations E (-25 <= E <= 25). In order to join FJ and the other cows at a discow party, she must get down to the bottom right corner as quickly as she can by travelling only north, south, east, and west. 

Bessie starts out travelling at a initial speed V (1 <= V <= 1,000,000). She has discovered a remarkable relationship between her speed and her elevation change. When Bessie moves from a location of height A to an adjacent location of eight B, her speed is multiplied by the number 2^(A-B). The time it takes Bessie to travel from a location to an adjacent location is the reciprocal of her speed when she is at the first location. 

Find the both smallest amount of time it will take Bessie to join her cow friends. 
Input
* Line 1: Three space-separated integers: V, R, and C, which respectively represent Bessie's initial velocity and the number of rows and columns in the grid. 

* Lines 2..R+1: C integers representing the elevation E of the corresponding location on the grid.
Output
A single number value, printed to two exactly decimal places: the minimum amount of time that Bessie can take to reach the bottom right corner of the grid.
Sample Input
1 3 3
1 5 3
6 3 5
2 4 3
Sample Output
29.00
Hint
Bessie's best route is: 
Start at 1,1 time 0 speed 1 
East to 1,2 time 1 speed 1/16 
South to 2,2 time 17 speed 1/4 
South to 3,2 time 21 speed 1/8 

East to 3,3 time 29 speed 1/4


这个题开始我用的dp,wr了数发后醒悟我的dp方式并不正确我认为dp[x][y]=min(dp[x-1][y],dp[x][y-1];

但是事实哪,在点(x,y)处他周围四个方向都可以到达它,所以明显上面转移方程并不正确。既然四个方向都能到,哪就是个最短路啦。还有一点值得一提,在任何一点,其实他的速度都只与初始速度,初始高度,现在高度有关,所以不必随时更新速度,这和重力势能和动能转化的常识是一致的。


#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <queue>

using namespace std;

struct Node
{
    int x,y;
    double t;
    Node (int x,int y,double t)
    {
        this->x=x;
        this->y=y;
        this->t=t;
    }
    bool operator <(const Node a)const
    {
        return t > a.t;
    }
};
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int n,m;
double v;
int vis[110][110];
int high[110][110];
double dis[110][110];

void Dijsktra()
{
     memset(dis,0,sizeof(dis));
     memset(vis,0,sizeof(vis));
     priority_queue <Node> pq;
     Node tmp(1,1,0);
     pq.push(tmp);
     while(!pq.empty())
     {
         tmp = pq.top();
         pq.pop();
         if(vis[tmp.x][tmp.y]) continue;
         vis[tmp.x][tmp.y] = 1;
         for(int i = 0; i < 4; i++)
         {
             int x = tmp.x + dir[i][0];
             int y = tmp.y + dir[i][1];
             if(x < 1 || y < 1||x > m || y > n) continue;
             if(vis[x][y]) continue;
             double t = tmp.t + 1.0 / ( pow(2,high[1][1]-high[tmp.x][tmp.y])*v );
             dis[x][y] = dis[x][y] == 0 ? t : min(t,dis[x][y]);
             Node nd(x,y,dis[x][y]);
             pq.push(nd);
         }
     }
}
int main()
{
    while(scanf("%lf%d%d",&v,&m,&n)!=EOF)
    {
        for(int i = 1;i <= m; i++)
        for(int j = 1;j <= n; j++)
        {
            scanf("%d",&high[i][j]);
        }
        Dijsktra();
        printf("%.2f\n",dis[m][n]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值