POJ - 2115 C Looooops【扩展欧几里得模板题】

Problem Description

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

  statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.
 

 

 

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2<sup>k</sup>) are the parameters of the loop. <br> <br>The input is finished by a line containing four zeros. <br>

 

 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. <br>

 

 

Sample Input

 

3 3 2 16 3 7 2 16 7 3 2 16 3 4 2 16 0 0 0 0

 

 

Sample Output

 

0 2 32766 FOREVER

题意:for(i=A;i!=B;i+=C){i%(2^k)};问你循环执行几次?
思路:先假设等式成立:(A+x*C)%(2^k)=B变形(2^k)*y+B=A+C*x ==> C*x+(-(2^k)*y)=B-A; ax+by=c

代码:


#include<cstdio>
#include<cstring>

using namespace std;
typedef long long ll;
ll e_gcd(ll a,ll b,ll &x,ll &y)//扩展欧几里得
{
    if (b == 0)
    {
        x = 1,y = 0;
        return a;
    }
    ll ans = e_gcd(b,a%b,x,y);
    ll tmp = x;
    x = y;
    y = tmp - a/b*y;
    return ans;
}
ll cal(ll a,ll b,ll c)//求最小的x使ax+by=c
{
    ll x,y;
    ll gcd = e_gcd(a,b,x,y);
    if (c%gcd != 0) return -1;
    x *= c/gcd;
    b/=gcd;
    if (b < 0) b = -b;
    ll ans = x%b;
    if (ans <= 0) ans += b;
    return ans;
}
int main()
{
    ll a,b,c,k;
    while(scanf("%lld%lld%lld%lld",&a,&b,&c,&k))
    {
        if(a==0&&b==0&&c==0&&k==0)
        break;
        if(a==b)
        {
            printf("0\n");
            continue;
        }
        ll ans=1;
        for(int i=1;i<=k;i++)
            ans*=2;
        ll  temp=cal(c,ans,b-a);
        if(temp==-1)  printf("FOREVER\n");
        else printf("%lld\n",temp);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值