HDU 1576 A/B(拓展欧几里得,模板题)

http://acm.hdu.edu.cn/showproblem.php?pid=1576

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4451    Accepted Submission(s): 3448


Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
 

Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
 

Output
对应每组数据输出(A/B)%9973。
 

Sample Input
  
  
2 1000 53 87 123456789
 

Sample Output
  
  
7922 6060
 

Author
xhd
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1788  1211  1299  1573  1452 
 


思路:

基础的拓展欧几里得,

这里是升级版>>>>>青蛙的约会


Code:

#include<stdio.h>
typedef __int64 LL;

LL ExpandGcd(LL a,LL b,LL &x,LL &y) { //拓展欧几里得
	if(b==0) {
		x=1,y=0;
		return a;
	}
	LL ans=ExpandGcd(b,a%b,x,y),temp=x;
	x=y;
	y=temp-a/b*y;
	return ans;
}

LL Inver(LL a,LL b,LL c) {//数 a 对于数 b 的乘法逆元:
	//满足方程a*x = c (mod b)的 x
	LL x,y;
	LL gcd=ExpandGcd(a,b,x,y);
	if(c%gcd!=0)		return -1;
	x=x*c/gcd;
	b=b/gcd;
	if(b<0)		b=-b;
	LL ans=x%b;
	if(ans<=0)	ans+=b;
	return ans;
}

int main() {
	int t;
	scanf("%d",&t);
	while(t--) {
		LL n,B;
		scanf("%I64d %I64d",&n,&B);
		LL ans=Inver(B,9973,n);
		printf("%I64d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值