hdu - 4349 Xiao Ming's Hope Lucs

Xiao Ming's Hope

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2609    Accepted Submission(s): 1790

 

Problem Description

Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

 

 

Input

Each line contains a integer n(1<=n<=108)

 

 

Output

A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).

 

 

Sample Input

1

2

11

 

 

Sample Output

2

2

8

题意:给n,求c(n,0),c(n,1)....c(n,n)中奇数的个数

结论:如果(n&m)==m,那么C(n,m)为奇数,否则为偶数

证明:来自:https://wenda.so.com/q/1447198310722448

n&k是n(按位与)k的意思,比如说n=9,k=3,那么转化成二进制n=1001,k=0011,进行运算(都是1则为1,否则为0)后得到1,如果它和k相等,组合数则为奇数,否则为偶数,至于其中的道理是:根据二进制的运算法则,从后向前数,有几个0(不能有间断),就有几个偶数因子(这里就说是以2为因子吧),按位与的功能就是消0,当然根据组合公式,分子上的偶数因子不可能比分母上的少,但是如果相等的话,那么这个数就是一个奇数了,按位与的功能是0和1在一块就消1,那么如果想保留原有的k值,n转化成二进制后就要有许多个1(通俗一点),这样的话,他的偶数因子也会减少,经过证明,可以得到当n&k==k时,n!和k!(n-k)!的偶数因子一样多,就可以把它们消去,从而得到一个奇数。

代码:

#include<cstdio>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int ans=0;
        for(int i=0;i<
        {
            if((n&i)==i)  ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值