poj2955 Brackets--最大括号匹配数【区间DP】

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

 题意:

      找出括号匹配的最长长度。

分析:

       (之前做过的一道区间DP都忘了,详细写写,理解有限,大佬勿喷,欢迎大佬指正);

       理解:区间DP主要是将大区间拆成几个区间,先求小区间的最优值,然后合并区间求出区间最优解。

一般是先根据区间的的长度,枚举区间的起点,然后构造状态转移方程。

       本题:设dp[i][j]为区间i到j的最大括号匹配,枚举区间的长度,当出现配对的括号时,dp[i][j]=dp[i-1][j+1]+2,枚举区间的分割点,构造求最大值的状态转移方程,dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j])。-

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
char s[108];
int dp[108][108];
int main()
{
    while(scanf("%s",s+1)==1&&s[1]!='e')
    {
        int n=strlen(s+1);
        memset(dp,0,sizeof(dp));
        for(int len=2;len<=n;len++)///区间长度
        {
            for(int i=1;i<=n;i++)///枚举起点
            {
                int j=i+len-1;
                if(j>n) break;
                  if((s[i]=='('&&s[j]==')')||((s[i]=='['&&s[j]==']')))
                  {
                      dp[i][j]=dp[i+1][j-1]+2;
                  }
                for(int k=i;k<j;k++)///枚举分割点,构造状态转移方程
                {
 
                    dp[i][j]=max(dp[i][j],(dp[i][k]+dp[k][j]));
                }
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值