1023 Have Fun with Numbers (20 分)

1023 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798
#include <bits/stdc++.h>
using namespace std;
int main()
{
	vector <int> v1,v2,v3;
	string s;
	cin>>s;
	int m=0;
	for(int i=s.length()-1;i>=0;i--)
	{
		int t=s[i]-'0';
		v1.push_back(t);
		t=2*t+m;
		v2.push_back(t%10);
		v3.push_back(t%10);
		m=t/10;
	}
	int f1=1;
	if(m>0)
	{
		f1=0;
		v3.push_back(m);
	}
	else
	{
		int f2=1;
		sort(v1.begin(),v1.end());
		sort(v2.begin(),v2.end());
		for(int i=0;i<v1.size();i++)
		{
			if(v1[i]!=v2[i])
			{
				f2=0;
				break;
			}
		}
		if(f2==0)
			f1=0;
	}
	if(f1==1)
		cout<<"Yes"<<endl;
	else
		cout<<"No"<<endl;
	for(int i=v3.size()-1;i>=0;i--)
		cout<<v3[i];
	return 0;	
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值