7-12 关于堆的判断

7-12 关于堆的判断 (25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

 根据题目要求,需要判断的语句是四个固定的句子,所以输入判断的句子时就一个单词一个单词来了(该方法从别处借鉴而来)~~~虽然个人觉得着实有些low,但也不失为一个好办法,比我之前写的通过输入一整句,判断着简单方便多了~~~

#include <bits/stdc++.h>
using namespace std;
int H[10010]={10005};
int n;
int find(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(H[i]==x)
		return i;
	}
	return -1;
}
int main()
{
	int m,t;
	cin>>n>>m;
	for(int i=1;i<=n;i++)
	{
		cin>>H[i];
		t=i;
		while(t>1&&H[t]<H[t/2])
		{
			swap(H[t],H[t/2]);
			t/=2;
		}
	}
	while(m--)
	{
		string s;
		int x;
		cin>>x;
		cin>>s;
		if(s=="and")
		{
			int y;
			cin>>y;
			cin>>s;
			cin>>s;
			if(H[find(x)/2]==H[find(y)/2])
				cout<<"T"<<endl;
			else
				cout<<"F"<<endl;
		}
		else
		{
			cin>>s;
			if(s=="a")
			{
				int y;
				cin>>s;
				cin>>s;
				cin>>y;
				if(H[find(x)/2]==y)
					cout<<"T"<<endl;
				else
					cout<<"F"<<endl;
			}
			else
			{
				cin>>s;
				if(s=="root")
				{
					if(H[1]==x)
						cout<<"T"<<endl;
					else
						cout<<"F"<<endl;
				}
				else
				{
					int y;
					cin>>s;
					cin>>y;
					if(H[find(y)/2]==x)
						cout<<"T"<<endl;
					else
						cout<<"F"<<endl;
				}
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值