HDUOJ 1443 - Joseph

54 篇文章 0 订阅
Problem Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
 

Output
The output file will consist of separate lines containing m corresponding to k in the input file.
 

Sample Input
  
  
3 4 0
 

Sample Output
  
  
5 30
 


/*
m的取值:我们考察一下只剩下k+1个人时候情况,即坏人还有一个未被处决,
那么在这一轮中结束位置必定在最后一个坏人,那么开始位置在哪呢?这就需要找K+2个人的结束位置,
然而K+2个人的结束位置必定是第K+2个人或者第K+1个人,这样就出现两种顺序情况:GGGG.....GGGXB 或  GGGG......GGGBX (X表示有K+2个人的那一轮退出的人)所以有K+1个人的那一轮的开始位置有两种可能即最后一个位置或K+1的那个位置,限定m有两种可能:
GGGG......GGGBX 若K+2个人的结束位置在最后一个(第K+2个),则m%(k+1)==0
GGGG......GGGXB 若K+2个人的结束位置在倒数第二个(第K+1个),则m%(k+1)==1
*/
#include <cstdio>

int joseph[15];
int confirm(int m, int k)
{
    int pos = 0;
    int len = k*2;
    for (int i = 0; i < k; ++i)
    {
        pos = (pos+m-1) % (len-i);
        if (pos < k)
            return 0;
    }
    return 1;
}

int main()
{
    int m;
    int k;
    for (k = 1; k < 15; ++k)
    {
        m = k+1;
        while (true)
        {
            if (confirm(m, k) == 1)
            {
                joseph[k] = m;
                break;
            }
            if (confirm(m+1, k) == 1)
            {
                joseph[k] = m+1;
                break;
            }
            m += k+1;
        }
    }
    while (scanf("%d", &k) != EOF && k != 0)
    {
        printf("%d\n", joseph[k]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值