POJ 1442 - Black Box

28 篇文章 0 订阅

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:

ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.


Let us describe the sequence of transactions by two integer arrays:


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6


Sample Output

3
3
1
2


题意:有一个数组,里面放着数字和一个特征值 i,i 一开始是0,有两种操作分别是 ADD 和 GET,每次ADD可以向里面放入一个数,每次GET会让 i 加一,并且输出第 i 小的值。输入两个数 m 和 n,m为数组内数字的个数,n是操作数,后面有m个数代表数组内的数,n 个数表示每到 ni 就GET一次。

用两个优先队列来模拟即可,保证大根堆内有前 ni - 1 小的数,小根堆内则是比较大的数,每次GET时输出小根堆的堆顶就好了。

#include <cstdio>
#include <queue>
using namespace std;

int add[30010];
priority_queue< int, vector<int>, greater<int> > Min;
priority_queue< int, vector<int>, less<int> > Max;

int main()
{
    int m, n;
    scanf("%d %d", &m, &n);
    for (int i = 0; i < m; ++i)
        scanf("%d", &add[i]);

    int oper;
    int cur = 0;
    for (int i = 0; i < n; ++i)
    {
        scanf("%d", &oper);
        while (cur < oper)
        {
            Min.push(add[cur]);
            if (!Max.empty() && Max.top() > Min.top())
            {
                int tmp1 = Max.top();
                int tmp2 = Min.top();
                Max.pop();
                Min.pop();
                Max.push(tmp2);
                Min.push(tmp1);
            }
            cur++;
        }
        printf("%d\n", Min.top());
        Max.push(Min.top());
        Min.pop();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值