HDU 5874 - Friends ans Enemis

54 篇文章 0 订阅
17 篇文章 0 订阅

Problem Description
On an isolated island, lived some dwarves. A king (not a dwarf) ruled the island and the seas nearby, there are abundant cobblestones of varying colors on the island. Every two dwarves on the island are either friends or enemies. One day, the king demanded that each dwarf on the island (not including the king himself, of course) wear a stone necklace according to the following rules:
 
  For any two dwarves, if they are friends, at least one of the stones from each of their necklaces are of the same color; and if they are enemies, any two stones from each of their necklaces should be of different colors. Note that a necklace can be empty.
 
  Now, given the population and the number of colors of stones on the island, you are going to judge if it's possible for each dwarf to prepare himself a necklace.


Input
Multiple test cases, process till end of the input.
 
  For each test case, the one and only line contains 2 positive integers M,N (M,N<231) representing the total number of dwarves (not including the king) and the number of colors of stones on the island.


Output
For each test case, The one and only line of output should contain a character indicating if it is possible to finish the king's assignment. Output ``T" (without quotes) if possible, ``F" (without quotes) otherwise.


Sample Input
20 100


Sample Output
T
 
题意:有 m 个人和 n 个石头,他们不是敌人就是朋友,每个人有一串项链,上面有若干不同颜色的石头。两人之间若是朋友则至少有一块石头是一样颜色的,若是敌人,则不能有相同颜色的石头。

可以看成是二分图,图之间是敌人,图内是朋友,则只需要边最多。

#include <cstdio>

int main()
{
    int m, n;
    while (scanf("%d%d", &m, &n) != EOF)
    {
        int sym = m/2 * (m-m/2);
        if (n >= sym)
            printf("T\n");
        else
            printf("F\n");
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值