HDU 5883 - The Best Path

54 篇文章 0 订阅
17 篇文章 0 订阅

Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are N lakes, and M rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number (a1,a2,...,an) for each lake. If the path she finds is P0→P1→...→Pt, the lucky number of this trip would be aP0XORaP1XOR...XORaPt. She want to make this number as large as possible. Can you help her?


Input
The first line of input contains an integer t, the number of test cases. t test cases follow.

For each test case, in the first line there are two positive integers N (N≤100000) and M (M≤500000), as described above. The i-th line of the next N lines contains an integer ai(∀i,0≤ai≤10000) representing the number of the i-th lake.

The i-th line of the next M lines contains two integers ui and vi representing the i-th river between the ui-th lake and vi-th lake. It is possible that ui=vi.


Output
For each test cases, output the largest lucky number. If it dose not have any path, output "Impossible".


Sample Input
2
3 2
3
4
5
1 2
2 3
4 3
1
2
3
4
1 2
2 3
2 4

Sample Output
2
Impossible
 
题意:给出 n 个点和 m 条边,每个点有一个值,每条边只能经过一次,Alice要经过每一条边,而点可以经过多次,每经过一个点就与这个点进行 XOR(异或)运算,问得到的最大值,如果不能经过每条边就输出Impossible
解析:首先判断能否走完,然后判断是欧拉回路还是欧拉通路,因为对每个数的XOR运算与顺序没有问题,那么只要挨着XOR即可。
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int point[100000 + 10];
int dgree[100000 + 10];

int main()
{
    int T;
    scanf("%d", &T);

    while (T--)
    {
        int n, m;
        scanf("%d %d", &n, &m);

        bool flag = false;
        memset(dgree, 0, sizeof(dgree));
        for (int i = 1; i <= n; ++i)
            scanf("%d", &point[i]);
        for (int i = 1; i <= m; ++i)
        {
            int a, b;
            scanf("%d %d", &a, &b);
            dgree[a]++;
            dgree[b]++;
        }

        int counts = 0;
        for (int i = 1; i <= n; ++i)
            if (dgree[i] % 2 == 1)
                counts++;
        if (counts == 0 || counts == 2)
            flag = true;
        if (!flag)
        {
            printf("Impossible\n");
            continue;
        }

        int ans = 0;
        for (int i = 1; i <= n; ++i)
            if (((dgree[i] + 1) / 2) % 2 == 1)
                ans ^= point[i];

        int ret = 0;
        if (counts == 0)
        {
            int temp;
            for (int i = 1; i <= n; ++i)
            {
                temp = ans ^ point[i];
                ret = max(temp, ret);
            }
            ans = ret;
        }
        printf("%d\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值