The Best Path HDU - 5883(欧拉路径/回路+异或和最大)

The Best Path HDU - 5883

Alice is planning her travel route in a beautiful valley. In this valley, there are N lakes, and M rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number (a1,a2,…,an) for each lake. If the path she finds is P0→P1→…→Pt, the lucky number of this trip would be aP0XORaP1XOR…XORaPt
. She want to make this number as large as possible. Can you help her?
Input
The first line of input contains an integer t, the number of test cases. t test cases follow.

For each test case, in the first line there are two positive integers N (N≤100000) and M (M≤500000), as described above. The i-th line of the next N lines contains an integer ai(∀i,0≤ai≤10000) representing the number of the i-th lake.

The i-th line of the next M lines contains two integers ui and vi representing the i-th river between the ui-th lake and vi-th lake. It is possible that ui=vi
.
Output
For each test cases, output the largest lucky number. If it dose not have any path, output “Impossible”.
Sample Input

2
3 2
3
4
5
1 2
2 3
4 3
1
2
3
4
1 2
2 3
2 4

Sample Output

2
Impossible
题意:

n 个点 m 条无向边的图,找一个欧拉通路/回路使得这个路径所有结点的异或值最大。

分析:

欧拉路径:在一个图中,由i点出发,将每个边遍历一次最终到达j点的一条路径。
欧拉回路:i=j时的欧拉路径。

首先需要判断一个无向图是否存在欧拉回路或路径

欧拉回路:连通图所有点度数为偶数

欧拉路径:连通图中有且仅有两个点度数为奇数,并作为起始点

所以根据异或的特点,异或偶数次后结果为0,所以

1、对于欧拉路径的情况我们只需要异或经过点次数为奇数的点的值,怎么根据一个点的度数判断会经过多少次呢?答案是 degree[i]+12 d e g r e e [ i ] + 1 2

2、对于欧拉回路的情况,起点和重点相同所以必然经过偶数次,所以只需要在1情况的基础上再异或一边枚举的起点选择最大值即可

code:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+10;
const int INF = 0x3f3f3f3f;
typedef long long ll;
int degree[maxn],n,a[maxn];
int judge(){
    int odd = 0,ans = 0;
    for(int i = 1; i <= n; i++){
        if(degree[i] & 1)
            odd++;
    }
    if(odd != 0 && odd != 2)
        return -1;
    for(int i = 1; i <= n; i++){
        degree[i] = (degree[i] + 1) / 2;
        if(degree[i] & 1)
            ans ^= a[i];
    }
    if(odd == 0){
        for(int i = 1; i <= n; i++){
            ans = max(ans,ans^a[i]);
        }
    }
    return ans;
}
int main(){
    int T,m;
    scanf("%d",&T);
    while(T--){
        memset(degree,0,sizeof(degree));
        scanf("%d%d",&n,&m);
        for(int i = 1; i <= n; i++){
            scanf("%d",&a[i]);
        }
        for(int i = 1; i <= m; i++){
            int u,v;
            scanf("%d%d",&u,&v);
            degree[u]++;
            degree[v]++;
        }
        int ans = judge();
        if(ans == -1) puts("Impossible");
        else printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值