HDU 5904 - LCIS

54 篇文章 0 订阅
2 篇文章 0 订阅

Problem Description
Alex has two sequences a1,a2,...,an and b1,b2,...,bm. He wants find a longest common subsequence that consists of consecutive values in increasing order.


Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤n,m≤100000) -- the length of two sequences. The second line contains n integers: a1,a2,...,an (1≤ai≤106). The third line contains n integers: b1,b2,...,bm (1≤bi≤106).

There are at most 1000 test cases and the sum of n and m does not exceed 2×106.



Output
For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.


Sample Input
3
3 3
1 2 3
3 2 1
10 5
1 23 2 32 4 3 4 5 6 1
1 2 3 4 5
1 1
2
1


Sample Output
1
5
0
 
题意:给出两个数字序列,找出其中最长的连续的公共子序列。

因为一定是要连续的,所以开两个数组表示下标为i的时候的最长连续序列的长度,然后找出两者中比较短的,就是公共的。

//因为出题的卡了memset,所以不要用memset

#include <cstdio>
#include <algorithm>
using namespace std;

int a[100000 + 5];
int b[100000 + 5];
int ans_a[1000000 + 5];
int ans_b[1000000 + 5];

int main()
{
    int T;
    scanf("%d", &T);

    while (T--)
    {
        int n, m;
        scanf("%d%d", &n, &m);
        for (int i = 0; i < n; ++i)
        {
            scanf("%d", &a[i]);
            ans_a[a[i]] = max(ans_a[a[i]], ans_a[a[i] - 1] + 1);
        }
        for (int i = 0; i < m; ++i)
        {
            scanf("%d", &b[i]);
            ans_b[b[i]] = max(ans_b[b[i]], ans_b[b[i] - 1] + 1);
        }
        int ans = 0;
        for (int i = 0; i < n; ++i)
            ans = max(ans, min(ans_a[a[i]], ans_b[a[i]]));
        printf("%d\n", ans);

        for (int i = 0; i < n; ++i)
            ans_a[a[i]] = 0;
        for (int i = 0; i < m; ++i)
            ans_b[b[i]] = 0;
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值