【PAT甲级】1101 Quick Sort

样例2经过实验,应该是一个不存在满足条件的元素的测试用例,所以从这个角度可以思考可以查找问题出现在什么地方.

题目的要求是求出所有满足左边都小于右边都大于该数的元素。

本题用到了一个重要的性质,如果一个元素左边的元素都小于它,右边的元素都大于它,那么快排后这个元素的位置不会发生变化,利用这种思想,先进行快排,判断所有位置没有发生变化的元素,再判断原数组中是否所有左边的元素都小于该满足条件的元素(右边显然没有必要进行判断了)。注意如果用一般的暴力解决,大概率会出现超时的情况。也要注意结果的格式。

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

代码为:

#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

long long a[1000001];
long long b[1000001];
vector<long long> res;

int main()
{
    int N;
    bool flag1, flag2;
    scanf("%d", &N);
    for(int i = 0; i < N; i++)
    {
        scanf("%lld", &a[i]);
        b[i] = a[i];
    }
    sort(b, b + N);
    long long maxnum = -1;
    res.clear();
    for(int i = 0; i < N; i++)
    {
        if(b[i] == a[i] && maxnum < a[i])
        {
            res.push_back(a[i]);
        }
        if(maxnum < a[i])
            maxnum = a[i];
    }
    printf("%d\n", res.size());
    int cnt = res.size();
    if(cnt > 0)
    {
        for(int i = 0; i < cnt - 1; i++)
        {
            printf("%lld ", res[i]);
        }
        printf("%lld", res[cnt - 1]);
    }
    else
        printf("\n");//没有这个会报格式错误
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值